Author Topic: New Users in Administrator not being added to shoppers  (Read 19052 times)

Mole

  • Beginner
  • *
  • Posts: 6
New Users in Administrator not being added to shoppers
« on: May 31, 2012, 08:05:48 am »
Running VM 2.0.7d, Joomla 2.5.3 on Apache & Linux

Long story short, finished off a large virtuemart install, lots of config and fiddling etc. but all running etc. All of a sudden now when new users are made in the Administrator they arent showing up as VM shoppers.

This is an issue as my client has certain shoppers they want to create themselves with elevated privileges (shopper group).

Have tried:
Install or Update tables button
Dropping all user related tables then using said button to recreate
Dropping ALL virtuemart tables and recreating via the tools
Downgrading, upgrading virtuemart + joomla (was running J! 1.7.3)
Upgrading virtuemart AIO component and etc's.

Users created through the Joomla frontend also dont get added as shoppers UNLESS added through Virtuemart itself.

If a shopper could be added directly through the Virtuemart admin there wouldnt be any problems...         

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9607
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: New Users in Administrator not being added to shoppers
« Reply #1 on: May 31, 2012, 13:47:23 pm »
Users without any shoppergroup are automatically in the default shoppergroup.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Mole

  • Beginner
  • *
  • Posts: 6
Re: New Users in Administrator not being added to shoppers
« Reply #2 on: June 01, 2012, 02:55:03 am »
Thats not the problem. Theres NO SHOPPER AT ALL for new users now. Before it would add a shopper albeit with lots of missing details (as expected).

Our client has 'special' users that they are making themselves and setting a different shopper group to.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9607
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: New Users in Administrator not being added to shoppers
« Reply #3 on: June 01, 2012, 18:46:59 pm »
All of a sudden now when new users are made in the Administrator they arent showing up as VM shoppers.      

What means you made a new user in the BE? Just create a user in joomla and you will see it appears as shopper, because it just uses the joomla list.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Mole

  • Beginner
  • *
  • Posts: 6
Re: New Users in Administrator not being added to shoppers
« Reply #4 on: June 05, 2012, 04:33:54 am »
I create a new user in the Joomla admin and it does not show in shoppers. Doesn't matter if its FE or BE.

I can send you some Joomla admin details if you want to check it out yourself.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9607
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: New Users in Administrator not being added to shoppers
« Reply #5 on: June 05, 2012, 10:07:43 am »
Okey, then do that.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Mole

  • Beginner
  • *
  • Posts: 6
Re: New Users in Administrator not being added to shoppers
« Reply #6 on: June 12, 2012, 08:46:42 am »
Sorry, been busy, have PMd details.

Mole

  • Beginner
  • *
  • Posts: 6
Re: New Users in Administrator not being added to shoppers
« Reply #7 on: June 22, 2012, 09:10:39 am »
Bump... still no fix for this.

Have tried updating to the latest Virtuemart and Joomla again, no improvement.

Looking at the vmusers table there are currently 13 entries but only 11 show up on the shoppers page - there are 16 actual users.

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.0.12
Re: New Users in Administrator not being added to shoppers
« Reply #8 on: June 23, 2012, 10:04:57 am »
I have come across the same issue - tested -

This is my test site with - standard VM , VM template and all VM standard test products.

1/   Image one is the Joomla registered users

2/  Image two is VM users after a page refresh

What happens is that they do not show up in the VM shop until they are logged in- and fixed all their address information.
* so the first time they come to my shop - they use their user name and password - and then their information is requested to be filled in.

* then when that is all complete they appear on the VM list .

* I'm sure this not the way that is expected but it works ?  Mole could you test and see if that works for you too.

Looking for ID 54

[attachment cleanup by admin]

Mole

  • Beginner
  • *
  • Posts: 6
Re: New Users in Administrator not being added to shoppers
« Reply #9 on: June 25, 2012, 02:49:31 am »
Thanks, I'll give that a try, if it works then at least that's a decent workaround for my issue.

Edit: That method worked well, thanks for the suggestion!

bernardobas

  • Beginner
  • *
  • Posts: 8
Re: New Users in Administrator not being added to shoppers
« Reply #10 on: August 03, 2012, 20:20:37 pm »
Hi guys. I had the same issue. My VM version is 2.0.8e / Revision: 6286. I solved it by replacing the file administrator/components/com_virtuemart/models/users.php with the same file from an older VM version (2.0.6 / Revision: 5917). Worked for me!!!

betalabs

  • Beginner
  • *
  • Posts: 1
Re: New Users in Administrator not being added to shoppers
« Reply #11 on: September 11, 2012, 08:36:54 am »
i have the same problem.i use now virtuemart 2.0.10 with joomla 2.5.6, but the problem stay. :(
i replace the user.php file with a older one but not solve my problem.any solution for this problem?????

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9607
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: New Users in Administrator not being added to shoppers
« Reply #12 on: September 13, 2012, 09:49:04 am »
oh heavens, please dont replace the usermodel with an old version. :o For me it works. And it is not connected  to the userinfo.
If it is connected to something then the __virtuemart_vmuserstable and the __virtuemart_vmuser_shoppergroups, we use:
Code: [Select]
SELECT DISTINCT ....  FROM #__users AS ju
LEFT JOIN #__virtuemart_vmusers AS vmu ON ju.id = vmu.virtuemart_user_id
LEFT JOIN #__virtuemart_vmuser_shoppergroups AS vx ON ju.id = vx.virtuemart_user_id
LEFT JOIN #__virtuemart_shoppergroups AS sg ON vx.virtuemart_shoppergroup_id = sg.virtuemart_shoppergroup_id

You may try the attached file (BE/models, rename to user.php). I enhanced a bit the sql, should work robuster now.

[attachment cleanup by admin]
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

_stu

  • Beginner
  • *
  • Posts: 21
Re: New Users in Administrator not being added to shoppers
« Reply #13 on: September 16, 2012, 07:19:45 am »
Milbo, I tried the file you uploaded, and received the following error:

Quote
Fatal error: Call to undefined method VirtueMartModelShopperGroup::appendShopperGroups() in /home/content/28/9553028/html/administrator/components/com_virtuemart/models/user.php on line 172

I'm running J 2.5.6 and VM 2.0.10. I have the same response as John2400. Once the user adds their billing address, they get added to the shopper list.

Once this is solved, I'd like to know how to add missing users to the shoppers list.

Thanks for your help.

John2400

  • Virtuemart - the Future is ever Changing
  • Global Moderator
  • Full Member
  • *
  • Posts: 1568
  • VirtueMart Version: Use VM3.0.12
Re: New Users in Administrator not being added to shoppers
« Reply #14 on: September 16, 2012, 07:22:28 am »
I just saw your post .

I updated to 2.0.11 try that - I think a few registration issues were solved here - just test for me and then post again.