Author Topic: Registration Problem: No Activation with Link possible  (Read 9990 times)

darbag

  • Beginner
  • *
  • Posts: 3
Re: Registration Problem: No Activation with Link possible
« Reply #15 on: August 19, 2012, 14:11:09 pm »
Does anyone know how to solve this problem? Many people have reported this problem but no concrete solutions. Why link activation work if the registration is with joomla but activation link does not work if the registration is with the VM??
Very please help.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10070
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Registration Problem: No Activation with Link possible
« Reply #16 on: August 19, 2012, 16:58:42 pm »
There is a solution. The problem is that you have a www. page. Joomla send you to www. but not the link generated from vm. The problem is that didnt find a way to solve it for all.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

darbag

  • Beginner
  • *
  • Posts: 3
Re: Registration Problem: No Activation with Link possible
« Reply #17 on: August 19, 2012, 21:05:10 pm »
Thank you for the quick response,
but  my site is www (http://www.kasy-fiskalne.info.pl/jupgrade/) and sent the activation link from vm is www.
 This is the activation link in joomla:
"http://www.kasy-fiskalne.info.pl/jupgrade/index.php?option=com_users&task=registration.activate&token=....."
and this is the activation link in vm:
"http://www.kasy-fiskalne.info.pl/jupgrade/index.php?option=com_users&task=registration.activate&token=...."
Activation in Joomla works fine in the VM is not working properly
Sometimes it works as an activation link paste it into IE9, I normally work on firefox
I have no idea what to do

CMYKreative

  • Jr. Member
  • **
  • Posts: 71
    • CMYKreative - Bangkok-based Advertising, Marketing, Graphic Design, Website Design & Development, Brand Identity, Logo Design, Search Engine Optimization (SEO), Hosting, Programming, Photography and Powerpoint Presentations from Bangkok, Thailand
Re: Registration Problem: No Activation with Link possible
« Reply #18 on: September 07, 2012, 03:33:10 am »
Reading through some of the other threads, it seems there is an issue with the activation link itself. By adding www into it, it works fine.

Try: http://forum.virtuemart.net/index.php?topic=99755.0

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10070
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Registration Problem: No Activation with Link possible
« Reply #19 on: September 08, 2012, 16:55:57 pm »
Atm I think the reason is a completly different one. It has something todo with alias, forwards and dns stuff.

I think you make www as alias, that is wrong. The www must be a forward to the non www URL
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

paping

  • Beginner
  • *
  • Posts: 6
Re: Registration Problem: No Activation with Link possible
« Reply #20 on: September 26, 2012, 05:41:36 am »
PM me for solution.. i got it :)