Author Topic: Live problem: add to cart very strange behaviour  (Read 5193 times)

Lorrein

  • Jr. Member
  • **
  • Posts: 80
  • Try our boardgame Lorrein. Its fun.
    • www.sensalot.com
Live problem: add to cart very strange behaviour
« on: May 11, 2012, 16:07:47 pm »
Hi, I'm running VM2.0.6, mulitlingual (en and NL) and I'm having serious issues with the add to card button and Card Module in the Live site!
(Artisteer template) www.sensalot.com

Situation 1
When I select the language Eng. The Add to cart button does nothing.

Situation 2
When I select NL, I can add 1 product ok. I choose "show the card" and I see 1 product in the component (this is correct). I also see 1 product in de Module basket. (also correct). When I update the amount to 2 I can see it in component and module (correct). But when I select show basket ( in de module), or click coontinue shopping or select a menu the amount changes back to one.

Situation 3
When a product is added to the basket, and the same category is browsed that the product is part of, this product is not shown in the module basket. So if two products from cat1 and cat2 are added and a customer continues shopping to cat3 the basket shows both products. But browsing to cat 2 will show only the cat1 product. This is not completely an accurate description because sometimes all is shown and sometimes non is shown

Situation 4
When 3 or more product are in the basket the thing becomes unexplainable.

Tried solutions:
Disabling many plugins using Java Script
installing jQuery Easy
disabling "Use external google jquery library"
disabling "Use external google jquery library"

I do no anymore.
Anyone

thanx
Arthur

 

Lorrein

  • Jr. Member
  • **
  • Posts: 80
  • Try our boardgame Lorrein. Its fun.
    • www.sensalot.com
Re: Live problem: add to cart very strange behaviour
« Reply #1 on: May 14, 2012, 16:00:11 pm »
Ok, some update: I've been working on it for days now and its driving me nuts.
When logged in the Cart component and module do what the should do. But when not logged in the strange behaviour occures, eg adding a second product is not saved. Since the customer only logs in after shopping (during checkout) this is not working for me.

I have purched and cleared cash
session handling is set to no
tried on/off "only registered users can checkout"

I get some jquery errors, but I don't know how to fix them (artisteer template).
Since it does work when a user is logged in, I guess it is not a jquery conflict.
Also tried innext en disabling jquery, but then the add to card buttons disappear.


What should I do, so guests can shop and buy multiple products and checkout?

DiveO2

  • Beginner
  • *
  • Posts: 47
  • Believe in yourself...
Re: Live problem: add to cart very strange behaviour
« Reply #2 on: May 15, 2012, 00:35:30 am »
I've reported something similar in the config pages...

http://forum.virtuemart.net/index.php?topic=102534.0
(Joomla! 2.5.4, VM 2.0.7c, PHP 5.3.10)   Do try and be clear & concise in your answers to fellow forum members, it will save confusion and frustration with the original poster (and future visitors) in re-asking the question again and again...

Lorrein

  • Jr. Member
  • **
  • Posts: 80
  • Try our boardgame Lorrein. Its fun.
    • www.sensalot.com
Re: Live problem: add to cart very strange behaviour
« Reply #3 on: May 15, 2012, 08:44:11 am »
I don't understand what your are trying to say.

franzpeter

  • 3rd party VirtueMart Developer
  • Jr. Member
  • *
  • Posts: 467
    • 2in1-online | Software, Mac, PC, Netzwerk, Drucker, Pad, Display
  • VirtueMart Version: Virtuemart 3.2.6
Re: Live problem: add to cart very strange behaviour
« Reply #4 on: May 15, 2012, 10:35:08 am »
@Lorrein and DiveO2,
I can confirm that the cart module produce some mess. Using another cart module (I have Ajax add to cart from Yagendoo) does work with one exception. It produces an error hint message while adding something to cart. I can configure that module to not show any hints, so it works in the frontend without annoying customers. So I think it has indeed something to do with the javascript VM 2 does use.

Lorrein

  • Jr. Member
  • **
  • Posts: 80
  • Try our boardgame Lorrein. Its fun.
    • www.sensalot.com
Re: Live problem: add to cart very strange behaviour
« Reply #5 on: May 15, 2012, 11:31:19 am »
I finally solved the problem.
Joomla setting: Cashing was at progressive. Changing this to conservative solved the problem about the card module not being updated.
disabling plugin system cash solved the problem where adding a second product to card isn't saved.
further more I have:
VM setting : Use external google jquery library = On
VM setting: Using the Virtuemart jQuery = On
J setting: Database type: changed it from MYSQLi to MYSQL



franzpeter

  • 3rd party VirtueMart Developer
  • Jr. Member
  • *
  • Posts: 467
    • 2in1-online | Software, Mac, PC, Netzwerk, Drucker, Pad, Display
  • VirtueMart Version: Virtuemart 3.2.6
Re: Live problem: add to cart very strange behaviour
« Reply #6 on: May 15, 2012, 12:00:07 pm »
@Lorrein,

thanks for the report. So VM 2 seems to have a bug with the Joomla cache. Normally it should be compatible with all cache settings. In case of system cache VM should take care about keeping the cache actual or renew the cache if any operation like add to cart or delete from cart a.s.o. occurs. It is an old VM problem. VM 1.1.xx did not work with system cache too.

Lorrein

  • Jr. Member
  • **
  • Posts: 80
  • Try our boardgame Lorrein. Its fun.
    • www.sensalot.com
Re: Live problem: add to cart very strange behaviour
« Reply #7 on: May 15, 2012, 12:39:08 pm »
OK one problem still remains. When selecting an other language the add to cart button (component) doesn't work.
When firste selecting dutch, then add a card, switch to english, I can alter the card (module and component).


Lorrein

  • Jr. Member
  • **
  • Posts: 80
  • Try our boardgame Lorrein. Its fun.
    • www.sensalot.com
Re: Live problem: add to cart very strange behaviour
« Reply #8 on: May 15, 2012, 13:52:13 pm »
Solved the problem regarding the add to card button not working after changing language:

In Plug-in: System - Language Filter
set  Remove URL Language Code to No



Florentp

  • Jr. Member
  • **
  • Posts: 86
Re: Live problem: add to cart very strange behaviour
« Reply #9 on: June 13, 2012, 18:58:56 pm »
A little "up" for that topic.
It is a solved problem, is there any way to fix that ?

The problem definitly come from the cache functionnality. Virtuemart don't seems to really support that functionnality.
Could we have some news about this issue ?

Thanks a lot.
Florent
Web programmer. Passionate.
PHP, SQL, Javascript, JQuery, css.
Skype : florent.indienboutique

Lorrein

  • Jr. Member
  • **
  • Posts: 80
  • Try our boardgame Lorrein. Its fun.
    • www.sensalot.com