Author Topic: default_pricelist.php: currencyDisplay->createPriceDiv(), shows only salesPrice  (Read 4525 times)

anupam_sam

  • Beginner
  • *
  • Posts: 14
J v2.5.4 VM 2.0.6

in the cart/default_pricelist.php

This is not showing anything for basePrice, taxAmount, discountAmount, ...
echo $this->currencyDisplay->createPriceDiv('salesPrice','', $this->cart->pricesUnformatted[$pkey],false);

What it shows is salesPrice or show nothing at all, price div is not created. Even if i give costPrice it is showing salesPrice.

But if i write $this->cart->pricesUnformatted[$pkey]['costPrice'] it shows the correct price i.e. without using currenyDisplay.

seems there are still issues with pricing?

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9997
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
?? wie? hä? was? I think you do not understand how the function works
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

anupam_sam

  • Beginner
  • *
  • Posts: 14
i don't know... i mean i upgraded VM from v2.0.3 to v2.0.6 & just took the default_pricelist.php & this is how its is showing the prices.

am i doing something wrong? plz let me know

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9997
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Did you stored the configuration at least one time?
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Sydiom

  • Beginner
  • *
  • Posts: 46
Getting same problem.

I am using VM 2.0.6 - (And by the way, I have tried to update it but I keep get "Maximum execution time of 30 seconds exceeded").
I am using Joomla 2.5.6

No matter how much I fiddle with the configuration pricing, the prices appear incorrectly.
  • I have a product on the page.
  • Base Price is £100
  • Tax is 20% more
  • Final Price is of course £120

The settings in configuration must be right. See attachments. In VM configuration I have set the Pricing to show:
  • SalesPrice without tax
  • Tax Amount
  • Final Sales Price

But I only get this on the browse and product detail display page - http://78.129.143.111/~bobbark/index.php/water-filters/water-filter-detail which is the Sales Price and the Sales price without tax and the figures are wrong.

Is there something I am doing wrong? Is there a bug?


[attachment cleanup by admin]

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9997
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
I am using VM 2.0.6 - (And by the way, I have tried to update it but I keep get "Maximum execution time of 30 seconds exceeded").

Change the execution time of your server or use the manual update (uploading to temp extracted and then use "install from directory".


Is there something I am doing wrong? Is there a bug?

You created a rule as price modifier before tax, just use tax or vattax
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Sydiom

  • Beginner
  • *
  • Posts: 46
Thank you Milbo. That worked.

To anyone else reading this, I used the option "Tax per Product".