Author Topic: Virtuemart auto-update fails - please help to solve! Thanks!  (Read 48354 times)

Yannick

  • Jr. Member
  • **
  • Posts: 82
    • Virtuemart Themes & Templates
Re: Virtuemart auto-update fails - please help to solve! Thanks!
« Reply #15 on: May 09, 2012, 15:04:35 pm »
@Michael78
Thanks, I updated the first post.

@rupesh
Please safe the config, clear your cache and reload the page.

@milbo
If you need us, we would be happy to sponsor a download-channel on our servers. I think it would the best if there is a "shuffle" in choosing the download-channel. But, this all not solve the issues with updating by the normal Joomla-installer. Or I am wrong?
Virtuemart Customizing  ==>  Virtuemart Themes, Templates & Extensions -  Verry Nice!

fug-mann

  • Beginner
  • *
  • Posts: 1
Re: Virtuemart auto-update fails - please help to solve! Thanks!
« Reply #16 on: May 10, 2012, 15:20:44 pm »
Trouble with vm2, any version to the newer one
vm aio the same

not known archive

a)  apache 2.2.22(ubuntu SMP)
b)  5.3.12-nmm2
c)  5.1.43-nmm4-log
d)  memory_limit = 64M
e)  max_execution_time = 30
f)   2.5.4
g)  2.0.0/2.0.2/2.0.4
h)  2.0.2/2.0.4/2.0.6  today, aio 2.0.6a to 2.0.6
i)   unknown archive typ, unable to extract
j)   all writable
k)  ..... .update.tar.gz in tmp - extraction on a pc not possible

ckliman

  • Beginner
  • *
  • Posts: 4
Re: Virtuemart auto-update fails - please help to solve! Thanks!
« Reply #17 on: May 10, 2012, 18:16:59 pm »
that's the message i get:


( ! ) Fatal error: Maximum execution time of 30 seconds exceeded in C:\wamp\www\mysite\administrator\components\com_virtuemart_allinone\classes\download.php on line 256
Call Stack
#   Time   Memory   Function   Location
1   0.0013   382920   {main}( )   ..\index.php:0
2   0.4285   5931392   JAdministrator->dispatch( )   ..\index.php:46
3   0.4553   6326352   JComponentHelper::renderComponent( )   ..\application.php:153
4   0.4792   6331208   JComponentHelper::executeComponent( )   ..\helper.php:357
5   0.4823   6423872   require_once( 'C:\wamp\www\mysite\administrator\components\com_virtuemart_allinone\admin.virtuemart_allinone.php' )   ..\helper.php:388
6   0.4885   6483040   LiveUpdate::handleRequest( )   ..\admin.virtuemart_allinone.php:46
7   0.5378   6900080   JController->execute( )   ..\admin.virtuemart_allinone.php:89
8   0.5379   6900136   LiveUpdateController->download( )   ..\controller.php:754
9   0.5740   7460592   LiveUpdateModel->download( )   ..\controller.php:75
10   1.0066   8138624   LiveUpdateDownloadHelper::download( )   ..\model.php:69
11   1.0137   8139176   LiveUpdateDownloadHelper::getFOPEN( )   ..\download.php:57

Yannick

  • Jr. Member
  • **
  • Posts: 82
    • Virtuemart Themes & Templates
Re: Virtuemart auto-update fails - please help to solve! Thanks!
« Reply #18 on: May 14, 2012, 08:22:35 am »
@Fug-Mann
Thanks, I add your data to the first post.

@clickman
Please set your "max_execution_time" of your server to a higher value and try it again. If you donĀ“t know how to, just contact your server admin. Can you please also post all your data (see first post) here?
Virtuemart Customizing  ==>  Virtuemart Themes, Templates & Extensions -  Verry Nice!

ckliman

  • Beginner
  • *
  • Posts: 4
Re: Virtuemart auto-update fails - please help to solve! Thanks!
« Reply #19 on: May 14, 2012, 09:59:07 am »
These informations are required:   
Apache Version 2.2.21
a) Server system   WampServer Version 2.2
b) PHP-version   / 5.3.8
c) SQL-version   / MySQL Version 5.5.16
d) memory_limit /   where do I get the info?
e) max_execution_time /   where do I get the info? and how to set?
f) Exact Joomla! version /   Joomla! 2.5.4
g) Exact Virtuemart version BEFORE update   / 2.0.0
h) Exact Virtuemart version of the update you want to/ 2.0.6 (2012-04-16)
i) Displayed error message   
j) Any not writable directory Permissions? /   where do I get the info?
k) Optional: Any other info?   

Thanks for the reply


Yannick

  • Jr. Member
  • **
  • Posts: 82
    • Virtuemart Themes & Templates
Re: Virtuemart auto-update fails - please help to solve! Thanks!
« Reply #20 on: May 16, 2012, 14:01:59 pm »
Hello Ckliman,

please check my first post, there are all locations explained. To change the max_execution_time, please contact your server-admin.
Virtuemart Customizing  ==>  Virtuemart Themes, Templates & Extensions -  Verry Nice!

ckliman

  • Beginner
  • *
  • Posts: 4
Re: Virtuemart auto-update fails - please help to solve! Thanks!
« Reply #21 on: May 16, 2012, 14:16:50 pm »
the server is on my netbook. (WAMP)
can you provide instructions how to change that setting?
It's my first time with joomla and virtue, servers, database...
It's all so confusing.

Thanks

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10213
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

amalia

  • Beginner
  • *
  • Posts: 5
Re: Virtuemart auto-update fails - please help to solve! Thanks!
« Reply #23 on: May 20, 2012, 21:07:47 pm »
Hello there, I also have a problem with autoupdate.

My info:

a) Apache/2.2.22  (Linux)
b) PHP/5.3.11
c) 5.5.23-log
d) memory limit = 128M
e) max_execution_time = 30
f) 2.5.4
g) 2.0.4
h) 2.0.6
i) Unable to decompress data Extracting the update package failed. Please try updating the extension manually.
j) all writable
k) none

Thanks :)

Yannick

  • Jr. Member
  • **
  • Posts: 82
    • Virtuemart Themes & Templates
Re: Virtuemart auto-update fails - please help to solve! Thanks!
« Reply #24 on: June 05, 2012, 19:12:53 pm »
Thank you Amalia, I updated the first post with your data!

@Milbo
Any news on this? Can we do anything else?
Virtuemart Customizing  ==>  Virtuemart Themes, Templates & Extensions -  Verry Nice!

dontflinch

  • Jr. Member
  • **
  • Posts: 152

astralavista

  • Beginner
  • *
  • Posts: 1
Re: Virtuemart auto-update fails - please help to solve! Thanks!
« Reply #26 on: June 09, 2012, 13:05:04 pm »
a) Apache: Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny9 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.

b) PHP: 5.2.6-1+lenny9

c) MYSQL Version: 5.0.51a

d) PHP Memory Limit: 128M

e) max_execution_time = where i can find these info?

f) 1.7.3

g) 2.0.1

h) 2.0.6

i) Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, pr@vdur.de and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny9 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g Server at kunde.werbeagentur-dr.com Port 80

j) all writeable

k) none

gldproducts

  • Beginner
  • *
  • Posts: 40
Re: Virtuemart auto-update fails - please help to solve! Thanks!
« Reply #27 on: July 10, 2012, 15:55:55 pm »
You all can just use the extension manager and it will automatically update virtuemart as well.  Just be sure to do a back up with Akeeba 1st. I was having the same problem, and then just said scre# it with the auto- update and the extension manager worked perfect.  ;D

Don Gould NZ

  • Beginner
  • *
  • Posts: 23
Re: Virtuemart auto-update fails - please help to solve! Thanks!
« Reply #28 on: July 20, 2012, 09:03:03 am »


        Unable to decompress data
        Extracting the update package failed. Please try updating the extension manually.



Can someone point me to the instructions to do a manual update?

I also see that stuff has to be writeable, can someone point me to instructions of what paths specifically need to be writeable?


Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10213
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Virtuemart auto-update fails - please help to solve! Thanks!
« Reply #29 on: July 20, 2012, 14:01:52 pm »
We got an update about this, seems like that some people got this error
" PHP Warning:  gzinflate() [<a href='function.gzinflate'>function.gzinflate</a>]: data error in"

and

"gzip: stdin: invalid compressed data--format violated
tar: Skipping to next header
tar: Child returned status 1
tar: Error is not recoverable: exiting now"

Maybe some tar.gz pro can tell us, why our tar.gzip programs work wrong. Btw, we used a windows and mac program, seems to be the same problem.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/