Author Topic: [solved] vmError: $link["view"] is empty  (Read 13540 times)

Urs

  • Jr. Member
  • **
  • Posts: 64
[solved] vmError: $link["view"] is empty
« on: April 04, 2012, 11:21:45 am »
Hello

Migrated a vm shop from vm1.1. to 2.0.3.i

Now i have on all vm pages a lot of vmError: $link["view"] is empty Lines.

Tried to delete the databases, reinstalled, different template, ... nothing helps!

Any ideas?

regards
Urs

Urs

  • Jr. Member
  • **
  • Posts: 64
Re: vmError: $link["view"] is empty
« Reply #1 on: April 04, 2012, 18:36:38 pm »
No one?

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10040
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: vmError: $link["view"] is empty
« Reply #2 on: April 04, 2012, 19:43:08 pm »
Go in your virtuemart entry of your joomla menu... and store it again... it has somethign todo with the sef and the joomla menu item stuff.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

Urs

  • Jr. Member
  • **
  • Posts: 64
Re: vmError: $link["view"] is empty
« Reply #3 on: April 04, 2012, 20:05:28 pm »
Thanks! Solved!

fire47

  • Jr. Member
  • **
  • Posts: 90
Re: [solved] vmError: $link["view"] is empty
« Reply #4 on: April 22, 2012, 01:03:09 am »
Didn't work for me, currently on v2.0.6

agrupe

  • Beginner
  • *
  • Posts: 45
Re: [solved] vmError: $link["view"] is empty
« Reply #5 on: May 04, 2012, 22:45:57 pm »
Not solved for me, too. The problem disappears only if I disable SEF in Joomla (2.5). VM 2.0.6

But that's not a solution at all ;-(

Andreas

fire47

  • Jr. Member
  • **
  • Posts: 90
Re:NOT SOLVED vmError: $link["view"] is empty
« Reply #6 on: May 10, 2012, 18:38:54 pm »
Still looking for a solution!!!!!  >:(

Sunglasses-Joe

  • Beginner
  • *
  • Posts: 26
  • Me & My Boy !
    • The Glasses Center
Re: [solved] vmError: $link["view"] is empty
« Reply #7 on: June 23, 2012, 13:08:36 pm »
I agree, Still NOT solved,
Only way to get rid is SEO Settings

    Search Engine Friendly URLs       Yes   No            to NO in Joomla config

ANyone any other ideas ?
The Glasses Center Group

http://www.sunglassescenter.co.uk/

Sunglasses-Joe

  • Beginner
  • *
  • Posts: 26
  • Me & My Boy !
    • The Glasses Center
Re: [solved] vmError: $link["view"] is empty
« Reply #8 on: July 16, 2012, 10:26:36 am »
Solved with VM2.0.8c

Thanks
The Glasses Center Group

http://www.sunglassescenter.co.uk/

manburg6

  • Beginner
  • *
  • Posts: 11
Re: [solved] vmError: $link["view"] is empty
« Reply #9 on: August 31, 2012, 15:17:08 pm »
Happen again with 2.0.10 but disable Joomla SEF does not works to solve problem.

Any other suggestion?

Thanks,
Mario

fire47

  • Jr. Member
  • **
  • Posts: 90
Re: NOT SOLVED vmError: $link["view"] is empty
« Reply #10 on: September 05, 2012, 20:52:25 pm »
This is a bug!  Admins/Devs please fix this!!!!!

wsfsb

  • Beginner
  • *
  • Posts: 5
Re: [solved] vmError: $link["view"] is empty
« Reply #11 on: October 16, 2012, 13:00:22 pm »
Not a bug, a warning.
As suggested, go back to your menu manager.  Any menu item that relates to virtuemart, reselect it and save.

In my case after migation from 1.1.9 to 2.12 there were old menu items, on edit the type is missing, press reselect, re-choose (cart or category layout) and save.

Jason

Lenfitz

  • Beginner
  • *
  • Posts: 4
Re: [solved] vmError: $link["view"] is empty
« Reply #12 on: November 21, 2012, 06:22:35 am »
Still have this problem. It is not solved.

Appears to be a SEF issue. No amount of resaving menu's fix's this error.

Turn off VM SEF and it dissappears. Turn on VM sEF and this error re-appears.

A fix please...

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3648
  • using Matomo instead of Google Analytics
Re: [solved] vmError: $link["view"] is empty
« Reply #13 on: December 19, 2012, 19:25:44 pm »
Just a guess - maybe an obsolete menu item in the joomla database??? (I did have that once long time ago - but I don't remember if I had the same warning)
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10040
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: [solved] vmError: $link["view"] is empty
« Reply #14 on: December 19, 2012, 23:25:53 pm »
I added a vmdebug, if vmdebug activated it should now show the problematic item
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/