Author Topic: Weird: Products / Categories not showing up in frontend at all  (Read 1648 times)

baggeler

  • Jr. Member
  • **
  • Posts: 57
    • Orgonite Brasil
I am using Joomla 2.5 and Virtuemart 2.02 (Which says on admin panel to be the newest release !?)

I am currently setting up a Virtuemart shop for the first time and I seem to be stuck somewhere OR with Product definition OR with the frontend modules:

Website: http://www.orgonite-brasil.com/

I started some days ago with definition of some products and later of a category/subcategory structure (see below).
I created a new menu (called Virtuemart menu) with menu items linked each to a categories layout and configured each to link to the respective (main) category.

What I expected was at Top Level to show all Categories of products and by clicking on this their subcategories and then again the products. But this is not the case...
  • All individual Categories (por Material, por Desenho etc.) show NOTHING AT ALL (see website) although there are both, products and subcategories attached to them!
  • Top Level shows some product icons yes, (but now it becomes weird) however these products are the first few test products I entered the first day in Virtuemart and they do not appear at all in my product table even in the backend... How is this possible? Where are those products? How can I debug? Is there somewhere a setting hiding products in backend depending on some criteria?[/li]
I seem not able to show in frontend any of the existing defined products or categories which I defined in the backend and - even more spooky than this is the fact that the products shown on Toplevel are not at all visible in the VM backend any more. What went wrong? Or am I understanding something wrong? Pls help, any hint about how where to start and debug is very apreciated!

Additional comment:
After thinking a lot about what happened between, I do remember now that I did first install original english VM, started testing by adding first products and then I installed portuguese language pack and above that complete VM spanish package... Could this be the source of the problem? Is the frontend somehow linked to another VM data than Backend? How can I test and verify this?



My Category Structure:t
by Material
- Copper
- Silver
- Gold
etc.

by Form:
- Piramid
- Sphere
- Oval
etc.

by Application:
- House
- Office
- Personal
etc.


Thanks a lot for any help
________________________________________
The more I know the more I know I don´t know
Socrates

Site: www.orgonite-brasil.com
Tech: Joomla 2.5.6,  Virtuemart 2.0.8e, PHP 5.3

baggeler

  • Jr. Member
  • **
  • Posts: 57
    • Orgonite Brasil
Re: Weird: Products / Categories not showing up in frontend at all
« Reply #1 on: August 28, 2012, 14:20:40 pm »
Its quite some time since I posted the message below. Nobody answered but I figured out myself the reason and want to share this here for all which may come across any similar problem.

The problem was that the products, categories etc. have been setup first, THEN I installed language packs for Joomla and Virtuemart etc. As Virtuemart has some pretty intransparent way of dealing with multilanguage, it just switched correctly the language to the new language but all products, categories etc. entred before simply disappeared. I found out they are still in database but just ignored. There is no way for any normal user to tell this as Virtuemart will not e.g. show a box with available languages and switch between them when you are on products or categories etc.

Simple Solution: You have to reenter all products and details to reappear under the second language.
________________________________________
The more I know the more I know I don´t know
Socrates

Site: www.orgonite-brasil.com
Tech: Joomla 2.5.6,  Virtuemart 2.0.8e, PHP 5.3

VirtueMart Forum

Re: Weird: Products / Categories not showing up in frontend at all
« Reply #1 on: August 28, 2012, 14:20:40 pm »