VirtueMart Forum

VirtueMart 2 + 3 => Product creation => Topic started by: kawagunax on December 20, 2011, 04:21:49 am

Title: Add Custom Fied to product not working (backend)
Post by: kawagunax on December 20, 2011, 04:21:49 am
Hi,

I really don't get it.

When I want to add a custom field to a product (in the backend tab), I have the drop menu showing the custom fields avalaible, no problem at this point.

But when I select one in the droplist, nothing happens, the custom field is not added to  the table below. I tried all the demo customs fields, I tried my own, I tried without the demo stuff...

I was thinking about an conflict, but everything is working perfect all around, so... I tried activate, desactivate JQuery, templates plugins, etc, but no succes.

Thanks to everyone that can help and thanks to the dev for their excellent work with VM !
Title: Re: Add Custom Fied to product not working (backend)
Post by: hugopt on December 20, 2011, 10:38:39 am
Same with me...
Title: Re: Add Custom Fied to product not working (backend)
Post by: StevenO on December 20, 2011, 17:18:55 pm
Same here...

But thanks for all the work, i like virtuemart
Title: Re: Add Custom Fied to product not working (backend)
Post by: Braindead83 on December 21, 2011, 13:51:57 pm
I have the same problem  :(
Title: Re: Add Custom Fied to product not working (backend)
Post by: PRO on December 21, 2011, 19:01:23 pm
is there a java error?
Title: Re: Add Custom Fied to product not working (backend)
Post by: kawagunax on December 23, 2011, 01:35:19 am
I'm a newbie so I don't kow if there's any relation with the issue.

Under the console of chrome, I have that when I go on the custom  field droplist :

event.layerX and event.layerY are broken and deprecated in WebKit. They will be removed from the engine in the near future.

Thanks !
Title: Re: Add Custom Fied to product not working (backend)
Post by: PRO on December 23, 2011, 18:44:04 pm
have you tried another browser
Title: Re: Add Custom Fied to product not working (backend)
Post by: kawagunax on December 27, 2011, 05:43:12 am
Absolutely, same issue with all latest browsers : FF, Opera, Safari, IE, Chrome...
Title: Re: Add Custom Fied to product not working (backend)
Post by: Braindead83 on December 28, 2011, 09:42:50 am
tried all ... no success
Title: Re: Add Custom Fied to product not working (backend)
Post by: PRO on December 28, 2011, 11:47:02 am
uncheck "use external google jquery"

BUT makes sure you still use virtuemart jquery
Title: Re: Add Custom Fied to product not working (backend)
Post by: morktron on December 29, 2011, 04:39:52 am
I had exactly the same problem, I tried unchecking "use external google jQuery" but it didn't fix it.

I made a copy of the site locally then one by one removed extensions with jQuery. It turned out Jom Social was causing the issue. When I unistalled it then VM extra fields worked again.

I wonder if there is some work around so that we can still use Jom Social and VM 2.0 ?
Title: Re: Add Custom Fied to product not working (backend)
Post by: Braindead83 on December 29, 2011, 12:13:42 pm
oh no  :( i need jomsocial AND vm
Title: Re: Add Custom Fied to product not working (backend)
Post by: morktron on January 16, 2012, 03:20:19 am
I see someone has narrowed down the issue further (http://forum.virtuemart.net/index.php?topic=96366.0)

It would be great if the most popular shopping cart for Joomla would work with the most popular membership solution for Joomla!
Title: Re: Add Custom Fied to product not working (backend)
Post by: renegadesk on January 24, 2012, 01:35:43 am
I've got it fixed for my install. check http://forum.virtuemart.net/index.php?topic=96366.0

Might not work with HTTPS but see how you go.
Title: Re: Add Custom Fied to product not working (backend)
Post by: morktron on January 24, 2012, 03:18:22 am
Good work Simon, many thanks, that has fixed it for my site :)