VirtueMart Forum

VirtueMart 2 + 3 => Virtuemart Development and bug reports => Topic started by: zylernjax on October 26, 2011, 23:56:21 pm

Title: [solved] VM2 Modules not filtering categories/products properly
Post by: zylernjax on October 26, 2011, 23:56:21 pm
Hey guys,


I am using the latest version of VM2, and whenever I create multiple copies of the VM modules on my front page (featured, new, random) and set each one to pull updates from a specific category, they won't change. It's like the "filter categories" function wont work properly.

Let's say I set 2 modules of (Virtumart Products) on the front page. If I set one to pull "random" from "cars category" and the other to pull "latest" from "trucks category"; each one will show the same product which neither is latest, random nor from that specific category.

OR;

If one module does manage to pull a random product from "truck category" - the other module will display the same exact product even when those parameters are set to choose from a completely different category.

You can see what I'm talking about here:  http://174.122.175.123/~willow/index.php/home

Each module on the front page keeps displaying the same products.

What am I doing wrong?
Title: Re: VM2 Modules not filtering categories/products properly
Post by: nflmerch on October 27, 2011, 00:03:12 am
I have this problem too.  Even with just 1 module, the filter does not seem to do anything
Title: Re: VM2 Modules not filtering categories/products properly
Post by: zylernjax on October 27, 2011, 00:32:34 am
I've seen this asked somewhere else and it never received a reply. Is there a solution? I don't think there is...
Title: Re: VM2 Modules not filtering categories/products properly
Post by: Milbo on October 27, 2011, 15:44:21 pm
We are on it, I think I know why
Title: Re: VM2 Modules not filtering categories/products properly
Post by: alatak on October 27, 2011, 19:08:41 pm
Hi,

Txs for reporting.
Fixed in revision 4568.
Title: Re: [solved] VM2 Modules not filtering categories/products properly
Post by: nflmerch on November 08, 2011, 00:59:24 am
I have subrelease K, and it seems like the behavior for this has reversed.  Now the only thing that will show is products from the category of the page you are on.  In other words, it is always filtering a category even when I have the category filter set to NO and Top Level Category
Title: Re: [solved] VM2 Modules not filtering categories/products properly
Post by: nflmerch on November 10, 2011, 00:38:37 am
I hope I am not misunderstanding the functionality of the Product module, but I still have this undesired behavior in subrelease M. 
Title: Re: [solved] VM2 Modules not filtering categories/products properly
Post by: Blakharaz on November 23, 2011, 15:22:54 pm
Same problem for me in the M Version. The Products are not filtered. I get products from all Categorys
Title: Re: [solved] VM2 Modules not filtering categories/products properly
Post by: geppie25 on November 23, 2011, 16:22:58 pm
Hi there,

I have the some problem, the featured products won't filter the category.

Is there already a solutions for this?

Thanks
Title: Re: [solved] VM2 Modules not filtering categories/products properly
Post by: notanothernumber on February 08, 2012, 01:49:59 am
I'm sharing your pain here. I have two virtuemart product modules running on the home page of my site (www.costumeglitz.com.au) . One is set to display featured products (which appears to be working fine) and the other is set to display the latest products which isn't working fine and pulling in incorrect data (i.e. not the latest product entered). I've attached screenshots of both the set-ups, anyone got any ideas what or where I'm going wrong??

[attachment cleanup by admin]