VirtueMart Forum

VirtueMart 1.1.x [ Old version - no longer supported ] => Administration & Configuration VM 1.1 => Topic started by: SoTrue on July 20, 2011, 13:37:18 pm

Title: 404 error when removing article from front page
Post by: SoTrue on July 20, 2011, 13:37:18 pm
Hi All,

I appear to be having a very odd problem. I have moved my random products module to the centre of the frontpage (ja_news i beleive) however the standard 'Joomla! Features' article is still below it even though i have disabled this for frontpage. I then unpublished the article completely...but when navigating ro my front page after that i get a 404 page error....very odd behaviour? Any help would be most appreciated.

Donna :)
Title: Re: 404 error when removing article from front page
Post by: jenkinhill on July 20, 2011, 15:13:18 pm
I guess you are new to Joomla. What you are seeing is not a VirtueMart issue, but I'd guess that you unpublished the default Joomla home page menu link? See http://forum.virtuemart.net/index.php?topic=66083.0

If you have SEF turned on in Joomla then turn it off as this can cause 404s at times, and does not work with VirtueMart.
Title: Re: 404 error when removing article from front page
Post by: SoTrue on July 21, 2011, 14:03:22 pm
You're correct, i havent built a store for a number of years, my previous experience was with OScommerce, so its all quite new to me :) I did manage to figure it out just before reading you post.

I had 2 default home pages, one was set as an article and that was the default, so hence unpublishing the article gave me that error. I switched this to the 'Other' home page and all is well. Thank you for your response :)