VirtueMart Forum

VirtueMart 2 + 3 => General Questions => Topic started by: TRIPLEdm on July 08, 2011, 18:05:31 pm

Title: VM2 & Joomla 1.7
Post by: TRIPLEdm on July 08, 2011, 18:05:31 pm
Will VM2 work with Joomla 1.7 or do we have an estimated date for version release that will work with Joomla 1.7?

In and all info appreciated and asking with greatest respect and gratitude for all the hard work the VM team puts in. THANK YOU IN ADVANCE!
Title: Re: VM2 & Joomla 1.7
Post by: Eugen S. on July 14, 2011, 20:37:35 pm
Will VM2 work with Joomla 1.7 or do we have an estimated date for version release that will work with Joomla 1.7?

In and all info appreciated and asking with greatest respect and gratitude for all the hard work the VM team puts in. THANK YOU IN ADVANCE!

it will work ;-)
Title: Re: VM2 & Joomla 1.7
Post by: jjk on July 14, 2011, 20:48:31 pm
It's already working on my Joomla 1.7RC test site  ;)
Title: Re: VM2 & Joomla 1.7
Post by: Minh BlackRed on July 15, 2011, 08:41:26 am
Forget 1.7 and think about 1.8 compatible  ;)
Title: Re: VM2 & Joomla 1.7
Post by: Milbo on July 15, 2011, 10:05:05 am
Forget 1.7 and think about 1.8 compatible  ;)
You got the point! ;-) . But as long j1.7 is there, we try to stay compatible. ATM it is working.
Title: Re: VM2 & Joomla 1.7
Post by: cshough on July 21, 2011, 21:17:54 pm
If virtuemart works with Joomla 1.7 why does the download link say that it is only for 1.5x??
Title: Re: VM2 & Joomla 1.7
Post by: Milbo on July 21, 2011, 22:57:23 pm
Which download link says it is only for j1.5?
Title: Re: VM2 & Joomla 1.7
Post by: ariesrei on July 22, 2011, 06:55:10 am
I am using J1.7 and VM 2.0 RC.
my problem is in the backend of vm2 the label says:
COM_VIRTUEMART_PRODUCT_LIST_LBL          - instead of Product List..
COM_VIRTUEMART_CATEGORY_LIST_LBL        - Category List
COM_VIRTUEMART_ORDER_MOD                    -Order and Customers
COM_VIRTUEMART_PAYMENT_METHOD_LIST_MNU   - aPayments and methods
Title: Re: VM2 & Joomla 1.7
Post by: jenkinhill on July 22, 2011, 13:04:54 pm
ariesrei which RC version? We are now at filename RC2c

http://forum.virtuemart.net/index.php?topic=85643.0
Title: Re: VM2 & Joomla 1.7
Post by: Amema on July 22, 2011, 22:58:09 pm
I have had some problems like ariesrei mentions (labels not being correct) but in other parts of Joomla 1.7. They all had to do with non-translated strings. Could that be the case?
Title: Re: VM2 & Joomla 1.7
Post by: Milbo on July 22, 2011, 23:07:10 pm
The problem is that the language files for j1.7 are very strict. The reason is to improve speed and performance.

When there is only one typo the language file does not work and then you see the language keys and not the translation. When you have problems with other components then take a look on the wiki here dev.virtuemart.net and in the wiki of joomla to correct it. Most time it is not soo much to do.
Title: Re: VM2 & Joomla 1.7
Post by: Rittermann on July 25, 2011, 09:40:16 am
I have problems making i work, when I try to publish a VM module i get only the following message:

Fatal error: Using $this when not in object context in /var/www/rittermann.org/cdl/libraries/joomla/plugin/plugin.php on line 102

What did I do wrong?
Title: Re: VM2 & Joomla 1.7
Post by: Milbo on July 25, 2011, 18:00:29 pm
This is a problem we had since yet only in j1.7 and did not had the time to address it yet. Sorry. since j1.6 we have adjust VM2 for every subversion and this takes a lot time. Should be done in the next subrelease.
Title: Re: VM2 & Joomla 1.7
Post by: kyovev on July 26, 2011, 14:31:56 pm
Hello. I am wondering if vm2 for joomla 1.7 is gonna become stable in the next 3-4 weeks ? I am asking, because i want to build site on the newest version but i can't wait a lot of time. I am not pushing anyone,  i just want to know.. because i read in some website that vm2 will be enough stable to be used with joomla 1.7 bu the end of the year. If this is true i will absolutely use joomla 1.5 and vm 1.1x, because i can't wait log..

Regards
Title: Re: VM2 & Joomla 1.7
Post by: Milbo on July 26, 2011, 17:21:01 pm
because i read in some website that vm2 will be enough stable to be used with joomla 1.7 bu the end of the year. If this is true i will absolutely use joomla 1.5 and vm 1.1x, because i can't wait log..
Where did you read that? Atm we are fighting only with the ACL of j1.7. So I think at august. In your case I would give vm2 and j1.5 a try.
Title: Re: VM2 & Joomla 1.7
Post by: kyovev on July 26, 2011, 19:55:34 pm
Milbo, thank you very much for the information - i will probably wait for 1/7. If my store go well i will  donate some cash to support this project.  Have a nice day ;)
Title: Re: VM2 & Joomla 1.7
Post by: imat on September 30, 2011, 08:36:50 am
Hi!

Is VM2 now safe to run with Joomla 1.7 for 'proper' site (ie not just for testing)?

Thanks :-)
Title: Re: VM2 & Joomla 1.7
Post by: jjk on September 30, 2011, 09:13:32 am
Depends  ;) - if you can get along with the basic shop functions, I would say yes. A few of the goodies built into VM2 still need some finetuning.
And at present the choice of payment plugins still is very limited. If you are new to VirtueMart 2, setting up the shop might take some learning time, because there is no user manual available at this time.
At the moment I would recommend to wait a few days for the RC1.9.8.H release, which fixes many small problems again.
Title: Re: VM2 & Joomla 1.7
Post by: imat on September 30, 2011, 10:17:30 am
Thanks jjk!

Are all the appropriate security measures stable? And does it accept Paypal?

:-)
Title: Re: VM2 & Joomla 1.7
Post by: imat on September 30, 2011, 10:18:31 am
Also, does 'a couple of days' really mean a couple of days or does it mean a couple of months? ;)
Title: Re: VM2 & Joomla 1.7
Post by: Milbo on September 30, 2011, 11:19:14 am
a couple of days means a couple of days.

Security,. hmm big issue. We did what we can do to make it safe. But we need some hackers who actually attack vm2 to see how safe it is.
Title: Re: VM2 & Joomla 1.7
Post by: patrickvbw on September 30, 2011, 13:21:55 pm
If i want to use VM as Catalogue only, would this version be ok to use in an production site?
Title: Re: VM2 & Joomla 1.7
Post by: Milbo on September 30, 2011, 13:29:25 pm
YES
Title: Re: VM2 & Joomla 1.7
Post by: imat on October 01, 2011, 03:33:56 am
Ok, thanks for your replies!

So when you say hackers to test security in VM2, are you referring to the version coming up in a couple of days?

And does it accept paypal?

:-)
Title: Re: VM2 & Joomla 1.7
Post by: imat on October 03, 2011, 03:39:17 am
And where can I read about the new release / how will I know when it's available?

Thanks :)
Title: Re: VM2 & Joomla 1.7
Post by: iTD on November 06, 2011, 21:58:32 pm
Which download link says it is only for j1.5?
Says it pertaining to v1.1.9 right here:
http://virtuemart.net/downloads

Which version do I use for Joomla 1.7???

Thanks!
Title: Re: VM2 & Joomla 1.7
Post by: alatak on November 07, 2011, 09:48:59 am
Hi,
For Joomla 1.7 , you should use the version
virtuemart1.9.8.RC2?_extract_first.zip

? being the latest from the list from that page:
http://dev.virtuemart.net/projects/virtuemart/files
Title: Re: VM2 & Joomla 1.7
Post by: NelsonB. on November 08, 2011, 23:35:42 pm
If virtuemart works with Joomla 1.7 why does the download link say that it is only for 1.5x??

Although this thread is somehow old, and I'm pretty sure this is the million dollar question that keeps repeating over and over everywhere, but really, is it Virtuemart latest released/stable version compatible with Joomla 1.7?

If so,  why does the download link say that it is only for 1.5x? (like the post quoted above)

Where is that link?
Here: http://virtuemart.net/downloads

"VirtueMart 1.1.9 is the latest stable version available. It is compatible with Joomla! 1.5.x only!"

I'm a developer and my company is ready to start working on this big humongous project where Virtuemart will fit perfectly for both the company and the client.

If I understand all of this correctly, VirtueMart 1.1.9 is compatible only with Joomla 1.5, BUT, VM2 is compatible with Joomla 1.7, am I right?

Could someone please give me a definitive answer?

Thanks in advance.

Nelson.
Title: Re: VM2 & Joomla 1.7
Post by: kpg on November 09, 2011, 11:37:29 am
Hi,

@NeslonB. The Url to find the latest Version is: http://dev.virtuemart.net/projects/virtuemart/files

It is Version M at the moment. And yes it is running on Joomla 1.7. x But i can't tell if it is perfect stable. It's a RC.  I made a sub-Joomla to test it.

Now i have my own question:

Beacause i don't want to wait to start filling the shop and change the default Layout's of it, i don't no if i can install the RC on a livesite without the risk of a security-issue and the problem of the Upgrade. When i upgrade the VM2 to the final release (hopefully soon) (and thanks for the work at this point) will it overried the allready made changes?

Thanks for the respond

Tobi
Title: Re: VM2 & Joomla 1.7
Post by: alatak on November 09, 2011, 11:40:07 am
Hi,

Quote
Beacause i don't want to wait to start filling the shop and change the default Layout's of it, i don't no if i can install the RC on a livesite without the risk of a security-issue and the problem of the Upgrade. When i upgrade the VM2 to the final release (hopefully soon) (and thanks for the work at this point) will it overried the allready made changes?

Template overwritting should be in the template folder.
If u do it that way, then an update will not overwrite your work.
Please read this:
http://dev.virtuemart.net/projects/virtuemart/wiki/Hints_for_the_use_of_the_template_system

Title: Re: VM2 & Joomla 1.7
Post by: kpg on November 09, 2011, 13:24:10 pm
Hi,

Thanks for the quick respond.
I do the temp. overwrites most of the time like that. It's as you said "safer".  But i never worked with VirtueMart before. However, Thanks for the links.

The Component still has some bugs. For example the Upgrade via akeeba live update. Or the config. of creditc. So i'm not sure if i should install the componet on the livesite for the build up. What would you recomend?

Regards

Tobi
Title: Re: VM2 & Joomla 1.7
Post by: Milbo on November 09, 2011, 13:33:07 pm
There are people already here using it on a live site, but it depends on the purpose (for exampel as catalogue is working already). You should also gain some experience with the RC first.
Title: Re: VM2 & Joomla 1.7
Post by: alatak on November 09, 2011, 14:34:25 pm
Hi,

Quote
Or the config. of creditc.
The configuration of the Credit Cards will be done by the payment plugin itself.
Title: Re: VM2 & Joomla 1.7
Post by: NelsonB. on November 09, 2011, 17:11:45 pm
Hi,

@NeslonB. The Url to find the latest Version is: http://dev.virtuemart.net/projects/virtuemart/files

It is Version M at the moment. And yes it is running on Joomla 1.7. x But i can't tell if it is perfect stable. It's a RC.  I made a sub-Joomla to test it.

Thanks Tobi. I'll check that out.
Title: Re: VM2 & Joomla 1.7
Post by: imat on November 15, 2011, 07:34:43 am
So when can we expect VM2 to be out of RC and good enough to be run on live site for store / shopping purposes?

I need it for a Joomla 1.7 site that is currently under development.

Thank you so much :-)

Edit: Worth mentioning, the site's built with a main focus on Jomsocial functionality. Will this first stable version be compatible with JS for reviews etc?
Title: Re: VM2 & Joomla 1.7
Post by: Milbo on November 16, 2011, 20:30:57 pm
We work together with community builder. There will be a plugin later for joomsocial also, we will see, who is going todo it.
Title: Re: VM2 & Joomla 1.7
Post by: dwlamb on November 21, 2011, 20:54:49 pm
I've followed this thread regarding use of Virtuemart and Joomla 1.7.  Where does one download VM2?  The download page only lists a link for vm 1.x which is not compatible with Joomla 1.7

Is there a hack people are employing by un-zipping the distribution and putting it in Joomla's extension directory manually?
Title: Re: VM2 & Joomla 1.7
Post by: PRO on November 21, 2011, 20:55:45 pm
I've followed this thread regarding use of Virtuemart and Joomla 1.7.  Where does one download VM2?  The download page only lists a link for vm 1.x which is not compatible with Joomla 1.7

Is there a hack people are employing by un-zipping the distribution and putting it in Joomla's extension directory manually?

in my signature
virtuemart1.9.8.RC2M_extract_first.zip
Title: Re: VM2 & Joomla 1.7
Post by: imat on November 22, 2011, 03:26:57 am
Thanks!

Sorry if I'm repetitive, but I still feel like I need a more concrete answer to the questions:

a. can I use VM2 live for shopping cart, or is it too unstable still?
b. If no, when can VM2 be expected to be stable enough for this purpose?

Thanks again :)

Title: Re: VM2 & Joomla 1.7
Post by: jenkinhill on November 22, 2011, 17:21:57 pm
Install it and start setting up the store, layout etc. By the time you have worked out how things are set up and styled the full release chould be available.
Title: Re: VM2 & Joomla 1.7
Post by: 911websiterepair on November 22, 2011, 18:36:12 pm
will that new release include all the standard shipping and payment modules

pp, ppp, auth.net, etc and UPS, USPS, Fedex       at least these three,    its currently useless without payment and shipping modules