VirtueMart Forum

VirtueMart Dev/Coding Central: VM1 (old version) => Virtuemart 1.1 Development (Archiv) => Quality & Testing VirtueMart 1.1.x => Topic started by: hendrix on September 02, 2009, 08:06:41 am

Title: "Add to cart" template change
Post by: hendrix on September 02, 2009, 08:06:41 am
I have posted this in the layout customisation thread first, but it might fit here better... There are some threads treating related topics, however, I have not yet found a working fix:

Description:
I have a custom made template for my homepage (default) and another one for the shop page.
When adding a product to the cart, the site jumps to the homepage layout, whereas Showcart and all other links are displayed in correct page/template (see attached). Any idea where to look at?

VirtueMart Version:
1.1.3 stable

Joomla/Mambo Version:
Joomla! 1.5.11

Steps to replicate:
see above

System info:
XAMPP v. 2.5 (localhost)
Windows XP Home, SP3

Let me know if I can help with any additional info to fix the issue.

Thank you,

Hendrik

[attachment cleanup by admin]
Title: Re: "Add to cart" template change
Post by: hendrix on September 02, 2009, 17:12:22 pm
I solved my problem by setting "Use Ajax to add, update or delete products from the cart?" to YES in the Theme settings: Virtuemart>Administration>Site>Layout>Configuration (components/com_virtuemart/themes/default/theme.config.php)
Title: Re: "Add to cart" template change
Post by: rian on September 30, 2009, 09:27:22 am
just for your information, this solved it for me:

http://forum.virtuemart.net/index.php?topic=34989.30

post#43 by pollar


i tried so much, but this seems to work in the end. the other proposed solution (changing the php_self to request_uri) worked until some point, but in checkout step2 i had the same problem again. but post #43 fixed everything!!!