VirtueMart Forum

VirtueMart 1.1.x [ Old version - no longer supported ] => Security (https) / Performance / SEO/ SEF issues VM 1.1 => Topic started by: cblunt on June 25, 2009, 11:58:12 am

Title: XMap and sh404sef
Post by: cblunt on June 25, 2009, 11:58:12 am
Hi forum,

Just getting to grips with Joomla 1.5 and Virtuemart 1.1.3 - fantastic technology.

However I'm having issues getting a sitemap running, I've installed XMap and the virtuemart extension, I think I have it configured correctly - told to display products and published the virtuemart plugin.

When I view the sitemap it shows my two menues but on the one that contains the category browser it only shows HOME, not categorys and no products.

I have implemented the latest version of sh404sef as well. This is working fine but I was  wodering if it's causing trouble with XMap.

I think I have the lastest versions of XMap and the plugin.

I know others have this configuration working - any help much appreciated.

Knd regards

Title: Re: XMap and sh404sef
Post by: cblunt on June 25, 2009, 16:36:47 pm
OK - I solved it.

I hadn't published the Virtuemart component on a menu, I was relying on the Show the Product Categories? option on my published Virtuemart module!  XMap must struggle with this.  As not to spoil the look of my site, I didn't publish the menu containing the Virtuemart component.  XMap still seems to be happy with this.

Thanks to anyone who took a look, and I hope my error helps someone else.

Kind regards

Title: Re: XMap and sh404sef
Post by: Peterw on June 26, 2009, 17:59:05 pm
I´ve same problem and I don´t know where is problem :(  I use VirtueMart 1.1.3 and Xmap with Virtuemart Plugin 1.1.1.

My works: internetový obchod (, sexshop (, erotické pomôcky (, vibrátory (, tréner (, byty (, pôžičky (
Title: Re: XMap and sh404sef
Post by: cblunt on June 28, 2009, 23:18:51 pm
In my case I had to add the VM Component to a menu, however you don't have to publish it. XMap still sees it and displays all your categories and products.

Another good tip it to login as admin and view your sitemap.html, you can then deselect pages from your sitemap.

It may help if you can post a link to your site.

Hope this helps.
Title: Re: XMap and sh404sef
Post by: fluidcontrols on April 06, 2010, 16:42:02 pm
hi cblunt
same question
please help me
Title: Re: XMap and sh404sef
Post by: brockda on June 09, 2010, 10:45:55 am
Hi fellow sufferers,

I have the same problem.
I use Xmap 1.2.7 with the VM plugin 1.1.3.
Although I have published vm in a menu it does not work.
Has someone already solved the problem?