VirtueMart Forum

VirtueMart General => Announcements => Topic started by: gregdev on July 31, 2008, 22:54:35 pm

Title: VirtueMart 1.1.2 Released
Post by: gregdev on July 31, 2008, 22:54:35 pm
VirtueMart 1.1.2 is a recommended maintenance update, which  provides enhancements and fixes a lot of minor bugs, including:


(see the changelog (https://dev.virtuemart.net/cb/wiki/2371) for full details).

Full installation packages and patch packages are available on the download page (http://virtuemart.net/index.php?option=com_content&task=view&id=54&Itemid=147).

To update to version 1.1.2, login to your VirtueMart administration area and choose "Check for Updates" from the "Admin" menu, then click the "Check now!" button and follow the instructions there. (Or, you can download the 1.1.2 patch package directly (http://virtuemart.net/index.php?option=com_content&task=view&id=54&Itemid=147) , save it to your local hard drive, and choose to "Upload a Patch Package" from the "Upload a Patch" tab.)

If you are using VirtueMart 1.1.0, you must first update to VirtueMart 1.1.1 before updating to VirtueMart 1.1.2.

Title: Re: VirtueMart 1.1.2 Released
Post by: David-Andrew on July 31, 2008, 23:02:14 pm
Hi Gregdev and other Developers/tester

I have just read the change log and mist say, you have done a really impressive job!

Thank you also for integration ccNewsletter, I am sure your and our users will love it. We will release ccNewsletter supporting this integration tomorrow.

For those that don't know ccNewsletter:
http://extensions.joomla.org/component/option,com_mtree/task,viewlink/link_id,5112/Itemid,35/ (http://ccNewsletter at extensions.joomla.org)

Gregdev, should I add ccNewsletter to your extension page?

Thank you again!

Regards
David
 
Title: Re: VirtueMart 1.1.2 Released
Post by: jasonyon on August 01, 2008, 00:09:27 am
For the "shipping bypass", does this do the same thing that Bob Bloom created?

Also, it looked like in the changelog that the last thing said about the shipping bypass was "shipping bypass did not work" on 04.07.2008
Title: Re: VirtueMart 1.1.2 Released
Post by: ufo_hk on August 01, 2008, 00:14:21 am
Wooow - just finished updating a test site with the built in updater and it worked beautifully.

Great, very impressive work - thanks.
Title: Re: VirtueMart 1.1.2 Released
Post by: gregdev on August 01, 2008, 00:20:47 am
For the "shipping bypass", does this do the same thing that Bob Bloom created?

Yes, Bob asked that it be integrated (thanks Bob!).

Edit: We have implemented an adaption of Bob's code. Please see Bob's post here (http://www.southlasalle.com/blog/core-virtuemart-with-my-bypass-demo-site/) for details.

Quote
Also, it looked like in the changelog that the last thing said about the shipping bypass was "shipping bypass did not work" on 04.07.2008

The comment in the change log just indicates the purpose of the change. In this case it means, "This change was made because it didn't work. Now it does work."

Greg
Title: Re: VirtueMart 1.1.2 Released
Post by: amorino on August 01, 2008, 05:00:29 am
Hello,

Thank you very much for this work but

I have :

Fatal error: Class vmsimplexml: Cannot inherit from undefined class jobject in /home/site/public_html/administrator/components/com_virtuemart/classes/simplexml.php on line 85

And when i try to go again to the upgrade utility i have this message.

Best regards
Amorino
Title: Re: VirtueMart 1.1.2 Released
Post by: jasonyon on August 01, 2008, 05:26:44 am
Glad to know it's supposed to work...

I just did the 1.1.1 and the 1.1.2 updates.

But, I am getting tons of errors though on the next step after I click the checkout button.

Quote
Error:Checkout needs a valid step!

Warning: in_array(): Wrong datatype for second argument in root/administrator/components/com_virtuemart/classes/ps_checkout.php on line 203

Warning: in_array(): Wrong datatype for second argument in root/administrator/components/com_virtuemart/classes/ps_checkout.php on line 203

And then, it's still wanting me to choose a shipping method

HELP!
Title: Re: VirtueMart 1.1.2 Released
Post by: gregdev on August 01, 2008, 06:01:45 am
Fatal error: Class vmsimplexml: Cannot inherit from undefined class jobject in /home/site/public_html/administrator/components/com_virtuemart/classes/simplexml.php on line 85

Which version are you updating from? 1.1.0? or 1.1.1? In either case, please see this post (http://forum.virtuemart.net/index.php?topic=42186.msg133721#msg133721).

Greg
Title: Re: VirtueMart 1.1.2 Released
Post by: gregdev on August 01, 2008, 06:08:50 am
Error:Checkout needs a valid step!

Warning: in_array(): Wrong datatype for second argument in root/administrator/components/com_virtuemart/classes/ps_checkout.php on line 203

Jasonyon,

I've created separate topic in the VM 1.1 Q&T forum (http://forum.virtuemart.net/index.php?topic=43897) to work through this. Please continue the discussion there.

Thanks,

Greg
Title: Re: VirtueMart 1.1.2 Released
Post by: internetdomain on August 01, 2008, 19:14:21 pm
This is just a reminder:

For those of you who install Virtuemart on clean Joomla installation, don't forget to turn on system legacy plugin. Otherwise you'll get global.php error when enabling Virtuemart modules.
Title: Re: VirtueMart 1.1.2 Released
Post by: gregdev on August 01, 2008, 20:01:34 pm
For those of you who install Virtuemart on clean Joomla installation, don't forget to turn on system legacy plugin. Otherwise you'll get global.php error when enabling Virtuemart modules.

This is not necessary. Did you download the right set of files? There are modules that are specifically for Joomla! 1.5. They do not require the legacy plugin (nor does the VirtueMart component). You can tell whether you have the right modules - they end with '.j15'.

Greg
Title: Re: VirtueMart 1.1.2 Released
Post by: james purcell on August 03, 2008, 13:10:53 pm
hi greg,
        i just upated from v1.1 to vm 1.2 went ok,i have a ? i wnt to have my stocked but i need out of stock items to orderable will this happen in future or is ther a way i can do this now? ;D
Title: Re: VirtueMart 1.1.2 Released
Post by: janaa1234 on August 08, 2008, 12:11:42 pm
As for myself I have had quite alot of problems after upgrading from 1.0.15 to 1.1.2 I needed "professional help" to solve different problems..

Theres still a couple of things that don't work:
I can not have only ONE payment method (that's what I want).. I need at least 2 payment methods, or I just get a en fatal error message...

Also the related products funktion doesn't work. When I search for a category or product there, it just searches but nothing is found...

I hope this problems are solved in next version...

Anyway - thanks for a gread component :-)
Title: Re: VirtueMart 1.1.2 Released
Post by: internetdomain on August 08, 2008, 20:26:13 pm
I don't know how you migrated your Joomla 1.0.x to J1.5, but for myself, the way I migrated is by installing a completely new clean J1.5 installation and all the necessary components. Then I did the database manipulation. That way will give me no error for every of my installed extensions.

Make sure you upgraded your Joomla correctly. Because by default, VM 1.1.2 can handle more than one payment method easily.  For related items, I just tried to modify one of my products, and it works fine either.

My suggestion for you, try to remove the payment method and readd. Also try to remove related items of one of your products and readd.
Title: Re: VirtueMart 1.1.2 Released
Post by: wdzinc on August 09, 2008, 17:21:23 pm
I hate to ask a silly question, but how do you turn the shipping bypass on for downloadable purchases? I've tried to find information on this but haven't been able too so far.
Title: Re: VirtueMart 1.1.2 Released
Post by: RolandD on August 10, 2008, 01:30:34 am
Go to Configuration under Admin. Click on Checkout, there you can choose what steps your customers have to take. Uncheck the shipping ones. That should do it.
Title: Re: VirtueMart 1.1.2 Released
Post by: amorino on August 11, 2008, 13:28:56 pm
Maybe it's a .htaccess problem
Title: Re: VirtueMart 1.1.2 Released
Post by: janaa1234 on August 11, 2008, 23:01:05 pm
Thanks for the advice, but the problem is that I can't uncheck the shipping... it's allready checked and can't be unchecked...??



Go to Configuration under Admin. Click on Checkout, there you can choose what steps your customers have to take. Uncheck the shipping ones. That should do it.
Title: Re: VirtueMart 1.1.2 Released
Post by: heidiheidi on August 14, 2008, 15:12:41 pm
The new 1.1.2 Download package on your frontpage does not seem to have the XML file in it that is needed to instruct Joomla how to install it. It absolutely will not install under Joomla 1.5 Auto Install function.

Heidi
Title: Re: VirtueMart 1.1.2 Released
Post by: joann on August 15, 2008, 20:47:11 pm
To janaa1234:

Do you still have problem with bypass shipping? If you don't, just disregard my post. This is what I did to disabled shipping:

Configuration--Admin: Under Shipping tab, select nothing. Under Checkout tab: uncheck the first two, then fill in "1" for Payment Method, and "2" for Confirmation.

Then to avoid error on the order edit, file /administrator/components/com_virtuemart/html/order.order_print.php on line 509, change from

if( $db->f("ship_method_id") ) {
$details = explode( "|", $db->f("ship_method_id"));
}

to:

if( $db->f("ship_method_id") ) {
$details = explode( "|", $db->f("ship_method_id"));
} else {
$details = array("","","","");
}

Hope this helps.

To heidiheidi: Try to download using Firefox. Mine can install properly. If you want I can email you the package.

Title: Re: VirtueMart 1.1.2 Released
Post by: headguru on January 04, 2009, 21:23:16 pm
I have Joomla 1.5.2 and as HeidiHeidi experienced, I get the following message when using the Auto Install function after I had already installed the autoloader.  "Error! Could not find a Joomla! XML setup file in the package. "

HELP!!