VirtueMart Forum

VirtueMart Dev/Coding Central: VM1 (old version) => Virtuemart 1.1 Development (Archiv) => Quality & Testing VirtueMart 1.1.x => Topic started by: Dave Dorson on February 08, 2008, 12:38:43 pm

Title: [UNDER REVIEW] Cannot Install VirtueMart 1.1 revision 1225 Complete Package
Post by: Dave Dorson on February 08, 2008, 12:38:43 pm
I get the following error when "going directly to shop" without installing sample data.

Code: [Select]
Update Log

Warning: installvirtuemart(/var/ares/webweavers/web/wedgedout/www.wedgedout.co.uk/public_html/administrator/components/com_virtuemart/classes/ps_database.php) [function.installvirtuemart]: failed to open stream: No such file or directory in /var/ares/webweavers/web/wedgedout/www.wedgedout.co.uk/public_html/administrator/components/com_virtuemart/install.php on line 112

Fatal error: installvirtuemart() [function.require]: Failed opening required '/var/ares/webweavers/web/wedgedout/www.wedgedout.co.uk/public_html/administrator/components/com_virtuemart/classes/ps_database.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/ares/webweavers/web/wedgedout/www.wedgedout.co.uk/public_html/administrator/components/com_virtuemart/install.php on line 112

Joomla! 1.5.0 Production/Stable [ Khepri ] 21-January-2008 23:55 GMT

PHP Built on:  Linux tripolis.areti.net 2.6.21.5 #1 SMP Thu Jun 14 16:29:23 BST 2007 i686 
Database Version:  5.0.45-5 
Database Collation:  utf8_general_ci 
PHP Version:  4.4.4-9 
Web Server:  Apache 
Web Server to PHP interface:  apache 

Using FireFox and IE gives the same error.

Don't know if you need anymore information?
Title: Re: Cannot Install VirtueMart 1.1 revision 1225 Complete Package
Post by: Dave Dorson on February 08, 2008, 12:55:43 pm
and when I try to un-install I get

Code: [Select]
Warning: com_uninstall(/var/ares/webweavers/web/wedgedout/www.wedgedout.co.uk/public_html/administrator/components/com_virtuemart/virtuemart.cfg.php) [function.com-uninstall]: failed to open stream: No such file or directory in /var/ares/webweavers/web/wedgedout/www.wedgedout.co.uk/public_html/administrator/components/com_virtuemart/uninstall.virtuemart.php on line 25

Fatal error: com_uninstall() [function.require]: Failed opening required '/var/ares/webweavers/web/wedgedout/www.wedgedout.co.uk/public_html/administrator/components/com_virtuemart/virtuemart.cfg.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/ares/webweavers/web/wedgedout/www.wedgedout.co.uk/public_html/administrator/components/com_virtuemart/uninstall.virtuemart.php on line 25
Title: Re: Cannot Install VirtueMart 1.1 revision 1225 Complete Package
Post by: Howard on February 08, 2008, 15:24:48 pm
If I remember correct I had a similar problem when I had FTP enabled with the Joomla global configuration. That did solve the directory/file owner problem but installation only worked halfway (the frontend files tar and admin files tar did not install hence missing files and directories). When FTP is disabled within the Joomla configuration the installation of VM goes all the way.

HTH
Title: Re: Cannot Install VirtueMart 1.1 revision 1225 Complete Package
Post by: mauri on February 08, 2008, 17:05:28 pm
I had same problem. Disable FTP .
 You must delete manualy folders:
/administrator/components/com_virtuemart
/components/com_virtuemart

And then, from Joomla! administration, uninstall virtuemart component. It gives error, but its OK.
If your Joomla! folders  have ftp owner, you must give write permissions(757) to folders:
/administrator/components
/components
/tmp

When installation is done, change folders permissions back to 755
Title: Re: Cannot Install VirtueMart 1.1 revision 1225 Complete Package
Post by: Dave Dorson on February 08, 2008, 17:16:15 pm
Brilliant :)

Cheers people I'll give that a go when I clock off and get back on my own machine :)
Title: Re: [UNDER REVIEW] Cannot Install VirtueMart 1.1 revision 1225 Complete Package
Post by: Dave Dorson on February 08, 2008, 19:11:39 pm
I can confirm that using mauri's instructions I have successfully installed VirtueMart 1/1

Thanks very much for the quick replies.

Note to developers, install does not work under FTP mode :) in Joomla 1.5.0 Stable :)
Title: Re: [UNDER REVIEW] Cannot Install VirtueMart 1.1 revision 1225 Complete Package
Post by: aravot on February 08, 2008, 19:21:24 pm
By ftp mode you mean inputing ftp configuration info during Joomla installation?
Title: Re: [UNDER REVIEW] Cannot Install VirtueMart 1.1 revision 1225 Complete Package
Post by: Dave Dorson on February 09, 2008, 11:01:24 am
By ftp mode you mean inputing ftp configuration info during Joomla installation?
Apologies.


Description:
Virtuemart v1.1 revision 1225 Complete Package for Joomla 1.5 does not install via the installer if  Enable FTP is set in Joomla under the global config settings in the admin backend.  When installing either sample data or going to shop, the errors outlined in my 1st post occur.

VirtueMart Version:
Virtuemart v1.1 revision 1225

Joomla/Mambo Version:
Joomla! 1.5.0 Production/Stable [ Khepri ] 21-January-2008 23:55 GMT

Steps to replicate:
Attempt to Install Virtuemart using the Joomla Installer with FTP Mode Enabled in the global configuration.

Proposed fix(es):
None, sorry I'm not a developer just willing to help test.

Bugtracker task #:
Can someone give me some pointers to this?, I'm lost.

System info:
PHP Built on:       Linux tripolis.areti.net 2.6.21.5 #1 SMP Thu Jun 14 16:29:23 BST 2007 i686
Database Version:    5.0.45-5
Database Collation:    utf8_general_ci
PHP Version:    4.4.4-9
Web Server:    Apache
Web Server to PHP interface:    apache
Joomla! Version:    Joomla! 1.5.0 Production/Stable [ Khepri ] 21-January-2008 23:55 GMT
User Agent:    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080207 Ubuntu/7.10 (gutsy) Firefox/2.0.0.12

(Please note, error under IE7 and Firefox)
Title: Re: [UNDER REVIEW] Cannot Install VirtueMart 1.1 revision 1225 Complete Package
Post by: mauri on February 09, 2008, 11:41:35 am
When Joomla! FTP mode is enabled:
The problem is that installer install component files and folders but did not unpack the admin_files.tar.gz and frontend_files.tar.gz files. When install continues (install demo products or go direct to shop) there are no files, because them are in tar.gz packing.
Title: Re: [UNDER REVIEW] Cannot Install VirtueMart 1.1 revision 1225 Complete Package
Post by: Soeren on February 09, 2008, 17:05:24 pm
Sounds like a bug in the Joomla! 1.5 FTP-based Installer...
Maybe someone should report the bug over at joomlacode.org.

ciao, Sören
Title: Re: [UNDER REVIEW] Cannot Install VirtueMart 1.1 revision 1225 Complete Package
Post by: Dave Dorson on February 09, 2008, 21:06:04 pm
Sounds like a bug in the Joomla! 1.5 FTP-based Installer...
Maybe someone should report the bug over at joomlacode.org.

ciao, Sören

Everything else appears to install perfectly well.
Title: Re: [UNDER REVIEW] Cannot Install VirtueMart 1.1 revision 1225 Complete Package
Post by: mauri on February 09, 2008, 21:42:14 pm
I think extensions have no FTP functionality.
Because. When installing virtuemart component and Joomla! FTP functionality is enabled, installation goes well so far it stops "The first step of the Installation was SUCCESSFUL" Now all just installed virtuemart folders ,files and xxx.tar.gz are owned to FTP.
Now you choice "install demo products" or "go direct to shop" , virtuemart installation continues(rename conf. dist, unpack tar.gz and install db.), but now virtuemart have no FTP rights anymore and cant handle files and folder who owns FTP.

When manually install virtuemart, it works but  eg. add image to product, the new image owner is noboby, not FTP.
Title: Re: [UNDER REVIEW] Cannot Install VirtueMart 1.1 revision 1225 Complete Package
Post by: mauri on February 09, 2008, 21:44:18 pm
Sounds like a bug in the Joomla! 1.5 FTP-based Installer...
Maybe someone should report the bug over at joomlacode.org.

ciao, Sören
Maybe this bug is same problem.
http://joomlacode.org/gf/project/joomla/tracker/?action=TrackerItemEdit&tracker_item_id=7515
Title: Re: [UNDER REVIEW] Cannot Install VirtueMart 1.1 revision 1225 Complete Package
Post by: Dave Dorson on February 10, 2008, 01:10:19 am
I see what you're both getting at now, yes, does look like a Joomla! issue.