VirtueMart Forum

VirtueMart 1.1.x [ Old version - no longer supported ] => Translation / Languages VM 1.1 => Topic started by: Pisu on February 07, 2008, 17:30:43 pm

Title: Language Manager for VM 1.1
Post by: Pisu on February 07, 2008, 17:30:43 pm
Here is the new Language Manager, updated for the completely new VM 1.1 (beta3 and onward) language structure!

Changes from VM 1.0:

Also, I added some useful features for translators:

Now you can: install VM 1.1 - upload official Language Pack - translate your language (one or more modules) - export translated modules, and post the updates here!

So translators, please use and test it, with the latest SVN revision!

Download here (1.1c, official):
http://dev.virtuemart.net/redmine/attachments/download/75/com_martlanguages_1.1c.zip

Download here (1.1d, some bug fixed):
http://www.vmitalia.net/index.php?option=com_docman&task=doc_download&gid=158&Itemid=58

Compatibility: Joomla 1.0.x and Joomla 1.5 with legacy mode.
Title: Re: Language Manager for VM 1.1
Post by: stowned on February 09, 2008, 13:06:31 pm
i have a problem ... i have up this changer i i cant change the language why ?? all language are included. If i set my user backend and fronted in german ... dont change it .. why ??? and in your component is not enable the current mosConfig_lang? is this normal ??? can i change this options in german ?
Title: Re: Language Manager for VM 1.1
Post by: iamalive on February 10, 2008, 22:09:01 pm
Hi

I just started to install the component and got the message that it required the legacy plugin. Aren't you going to make a Joomla 1.5 fully compatible version?

Regards

David
Title: Re: Language Manager for VM 1.1
Post by: Pisu on February 14, 2008, 19:04:12 pm
I just started to install the component and got the message that it required the legacy plugin. Aren't you going to make a Joomla 1.5 fully compatible version?
I wish to do it, but not soon, I have very little time, sorry... And in fact, I think this is not a big problem, as this is a one-shot component for translators...,
Title: Re: Language Manager for VM 1.1
Post by: pedrohsi on March 05, 2008, 14:02:09 pm
this component does not contain the updated strings that appeared in 1.1 rev 1289 - it does not show the missing strings for version update and canadapost pages, neither in the original english or in my hungarian language files

is this intended?
Title: Re: Language Manager for VM 1.1
Post by: Pisu on March 11, 2008, 19:21:06 pm
He Language Manager component DOES NOT contain any string!! They are dinamically read from VM.

But: after updating VM, you have to click on "REBUILD TOKENS", for made the component re-read all strings.
Title: Re: Language Manager for VM 1.1
Post by: pedrohsi on March 11, 2008, 19:24:25 pm
understood, i was thinking about that :) thank you
Title: Re: Language Manager for VM 1.1
Post by: alatak on March 13, 2008, 10:54:08 am
Hi,

Just troed your 1.1.C version.

When rebuilding the tokens, it updated my french languages files with  the english strings but ther strings with quotes are not escaped.

Title: Re: Language Manager for VM 1.1
Post by: Pisu on March 17, 2008, 18:48:00 pm
Hi,

Just troed your 1.1.C version.

When rebuilding the tokens, it updated my french languages files with  the english strings but ther strings with quotes are not escaped.
Yes, I noticed some problems with French files... Have you made them working?
Title: Re: Language Manager for VM 1.1
Post by: alatak on March 17, 2008, 18:56:17 pm
Hi,

Quote
Yes, I noticed some problems with French files... Have you made them working?

I use your component to rebuild the tokens, but then after it is easier for me (I am doing the french translation) to to do the translation directly in an editor. So I made the quote correction direclty on the file.

But I do have the problem each time I want to rebuils the tokens.
Title: Re: Language Manager for VM 1.1
Post by: grgBuilder on March 25, 2008, 00:00:14 am
After I click Apply or Save even if I haven't changed anything I get the following error

Code: [Select]
Parse error: syntax error, unexpected T_STRING, expecting ')' in
/administrator/components/com_virtuemart/languages/common/greek.php on line 1121
Title: Re: Language Manager for VM 1.1
Post by: Pisu on March 30, 2008, 19:39:41 pm
uhm... can you report the content of that line 1121, when you get the error?
Title: Re: Language Manager for VM 1.1
Post by: korb on March 31, 2008, 01:47:39 am
Hei
I like the language manager, but if I modify again (from unicode UTF8) to iso 85...
How can i be sure this is the final adjustement to VM language standard? I mean there is goin to be another change from iso to unicode?
Thanks and wair for an answer
Title: Re: Language Manager for VM 1.1
Post by: alatak on March 31, 2008, 09:03:37 am
Hi,

For french translation I have the following problem:

If I don't translate everything in a file, then the engllish version of the string is inside the file. For those english strings the quote character is not escaped (\')

Title: Re: Language Manager for VM 1.1
Post by: Pisu on March 31, 2008, 09:34:01 am
Hei
I like the language manager, but if I modify again (from unicode UTF8) to iso 85...
How can i be sure this is the final adjustement to VM language standard? I mean there is goin to be another change from iso to unicode?
Thanks and wair for an answer

In VM 1.1 there are no charset problems! After converting files, you only have to change the "CHARSET" parameter inside the file (opening with a text editor), with "UTF-8" value.

(Please avoid double posts.... )
Title: Re: Language Manager for VM 1.1
Post by: alatak on March 31, 2008, 10:37:38 am
Hi,
Quote
or french translation I have the following problem:

If I don't translate everything in a file, then the engllish version of the string is inside the file. For those english strings the quote character is not escaped (\')

Sorry about this post just a few hours before. I have done again, and I don't have this problem any more.
Title: Re: Language Manager for VM 1.1
Post by: Pisu on April 01, 2008, 08:08:27 am
good :)
Title: Re: Language Manager for VM 1.1
Post by: korb on April 03, 2008, 17:02:45 pm
PLS help a bit..
How will I complete the comon language file? I have observed that the english version is bigger with about 15 KB, and about 80 code lines AND appears that the added code lines are from CMN_YEARS=Years.
QUESTION! Can I simply copy paste the lines below that line from the en lang to my lang file? I mean I already did that but, can damage the functionality of my VM instalation?
Title: Re: Language Manager for VM 1.1
Post by: iamalive on April 15, 2008, 16:17:29 pm
Hi

I've translated most of the rest of the common German language file which hadn't been done (from about line 712 onwards), because I need this for a client.

The only bits I left out are those concerned with shipping and payment moduls, as I don't need these at the moment. I've used the language file out the the VirtueMart 1.1 revision 1369 from the 14th of April.

I hope it helps

[attachment cleanup by admin]
Title: Re: Language Manager for VM 1.1
Post by: alatak on April 15, 2008, 16:55:12 pm
Hi,

Here
http://virtuemart.net/index.php?option=com_content&task=view&id=285&Itemid=57

Soren has asked us to put the languages files here:

https://dev.virtuemart.net/cb/proj/doc.do?doc_id=1659
Title: Re: Language Manager for VM 1.1
Post by: Pisu on April 15, 2008, 19:08:40 pm
PLS help a bit..
How will I complete the comon language file? I have observed that the english version is bigger with about 15 KB, and about 80 code lines AND appears that the added code lines are from CMN_YEARS=Years.
QUESTION! Can I simply copy paste the lines below that line from the en lang to my lang file? I mean I already did that but, can damage the functionality of my VM instalation?
If you use the Language Manager, it will write the needed lines (missing fields will be red before translating, but it's not a problem).

Hi,
Here
http://virtuemart.net/index.php?option=com_content&task=view&id=285&Itemid=57
Soren has asked us to put the languages files here:
https://dev.virtuemart.net/cb/proj/doc.do?doc_id=1659
Yes please! Or at least attach in the correct post in forum.. not here

Title: Re: Language Manager for VM 1.1
Post by: iamalive on April 15, 2008, 21:12:15 pm
OK, I've copied there, as suggested.

Quote
Soren has asked us to put the languages files here:

https://dev.virtuemart.net/cb/proj/doc.do?doc_id=1659 (https://dev.virtuemart.net/cb/proj/doc.do?doc_id=1659)

Regards
Title: Re: Language Manager for VM 1.1
Post by: korb on April 16, 2008, 00:13:22 am
Thanks Pisu
Title: Re: Language Manager for VM 1.1
Post by: karabasik on May 13, 2008, 17:24:05 pm
Hello Guys,

I have installed this Martlanguages, uploaded language pack. I can see the list of languages in this Language manager, but how can I activate it? to make it default?
Title: Re: Language Manager for VM 1.1
Post by: karabasik on May 13, 2008, 17:25:09 pm
Oppps sory, somehow it works!
Title: Re: Language Manager for VM 1.1
Post by: A K on May 26, 2008, 04:33:48 am
Hi.
Language Manager works EXTREMELY slow in IE7 when opening tokens for editing.
In firefox and opera everything is ok.

Just wanted to let you know.
Title: Re: Language Manager for VM 1.1
Post by: alexxsav on May 27, 2008, 11:48:31 am
Hei
I like the language manager, but if I modify again (from unicode UTF8) to iso 85...
How can i be sure this is the final adjustement to VM language standard? I mean there is goin to be another change from iso to unicode?
Thanks and wair for an answer
In VM 1.1 there are no charset problems! After converting files, you only have to change the "CHARSET" parameter inside the file (opening with a text editor), with "UTF-8" value.
(Please avoid double posts.... )
Its strange... But i want to use russian lang and change charset to windows-1251 but it still wrong ///like that :PHPSHOP_ERROR
ERROR  Ошибка
Title: Re: Language Manager for VM 1.1
Post by: alexxsav on May 27, 2008, 12:11:17 pm
It is because the file is in utf-8 to change charset you must to change file charset of russian.php to cp1251
Title: Re: Language Manager for VM 1.1
Post by: Pisu on May 31, 2008, 07:53:37 am
It is because the file is in utf-8 to change charset you must to change file charset of russian.php to cp1251

In VM 1.1, revision 1402 (you can download a nightly build), I added the conversion function from utf-8 to cp1251. So if you have Joomla with cp1251 charset, it will work automatically.
Title: Re: Language Manager for VM 1.1
Post by: kebiter on June 12, 2008, 04:48:46 am
hi i want to download VM1.10 stable chinese languages.

could you send it to me .

i use joomla 1.53 and vm 1.10stable version.

thank you all!
Title: Re: Language Manager for VM 1.1
Post by: epareja on June 12, 2008, 07:28:14 am
Pisu:

Thank you very much for this tool.  Solve all my problems! ;D
Title: Re: Language Manager for VM 1.1
Post by: ROBINJG on June 17, 2008, 22:08:48 pm
Hi, I was wondering why the "publish" button doesen't exist in the 1.1C version? If it's not supposed to exist, how do I change language from english to any other language?
Title: Re: Language Manager for VM 1.1
Post by: Marcis on June 19, 2008, 11:29:12 am
Same here - How can I publish Language in 1.1C version?
Title: JFolder::create: Could not create directory
Post by: kingnuss on June 24, 2008, 21:36:17 pm
when installing any language pack, this error appears:
Quote
JFolder::create: Could not create directory

got vm 1.1, language manager component and legacy mode joomla 1.5.3
apache server, safe mode is off
chmod issue? all necessary joomla folders are writable

any ideas? found no solution on google or forum here

 
Title: Re: Language Manager for VM 1.1
Post by: Jonne on June 25, 2008, 23:28:50 pm
With this component I can only edit the "Account" module...
No other modules are shown in the dropdown box where you change the module to edit...
Title: Re: Language Manager for VM 1.1
Post by: x-litero on June 27, 2008, 16:14:48 pm
hi guys,

I have the same problem as described above!
Installed everything, got the language pack in need and uploaded it.
everything perfect but where can I apply it???
(http://www.philippheller.de/images/fotos/language_screen.jpg)
Title: Re: Language Manager for VM 1.1
Post by: Larry Rooney on July 02, 2008, 01:46:01 am
I experienced the same problem myself with IE and FF.
Title: Re: Language Manager for VM 1.1
Post by: x-litero on July 02, 2008, 15:05:11 pm
yeah i used firefox, can nobody solve this prolbem? i think without a solution this komponent is just unuseable???!!!

greets
Title: Re: Language Manager for VM 1.1
Post by: represent on July 03, 2008, 12:08:52 pm
So what is the deal? All the thai code in the lang pack charsets are utf-8, and all it shows is crap stuff - no thai... is this actuallythai code? or just crap. Does it need to be incoded first somehow? Or did soem one not save it in the right format so it turned to crap before uploading the lang pack ? that is my guess.
Title: Re: Language Manager for VM 1.1
Post by: cherylcollier on July 08, 2008, 10:43:57 am
Hi, am new to virtuemart and joomla, I think they're great, I have successfully installed the Joomla_1.5.3_eCommerce_Edition_VM_1.1.0.tar.gz. Now I want to install multi languages. I have downloaded your file, where do I install it to? Or where do I unpack it to? Which directory should the files go in? I am experienced php, mysql, css and actionscript programmer and designer.
Title: Re: Language Manager for VM 1.1
Post by: x-litero on July 09, 2008, 23:47:12 pm
hi cherylcollier,

you can install joomla components and ads by using the joomla backend. you have to go to the "extensions" menu, there you have to choose the install/uninstall menu....
now you have to choose the file you like to upload, in fact what you downloaded. you do not have tu unpack the file!

just upload the package and enjoy...joomla does everything for you, some plugins you have to activate in the extensions-->plugin manager menu.

please tell us your expiriences with the language manager. my problem is not fixed yet...

greetz
Title: Re: Language Manager for VM 1.1
Post by: Andragon on July 12, 2008, 00:26:18 am
Hi All

I have everything installed propertly, Joomla 1.5.3 lagacy mode, VirtueMart1.1.1, Joomfish 2.o Beta, VM Language Manager (com_martlanguages_1.1c) and my spanish version is all translated (well most of what I need) BUT VM translation is not showing!!! What could I be doing wrong? Any trick or procedures i am not aware of?

Could you take a look at http://www.logoxpert.net please and let me know. Thank you!
Title: Re: Language Manager for VM 1.1
Post by: mmarch on August 06, 2008, 15:02:29 pm
hello, i have the same problem - on my site installed 2 languages - English and Latvian. VM show only english.

Before i found this component To solve language problem i just replaced english files with Latvian files. Everything in this situation was OK except one thing - date format. When you are browsing joomla content date show right language but when browse WM shop categories - date format language switch to English. I changed English records on Latvian records, checked databases but unsuccessfully.

Then i found this WM language component, i put back English files, but anyway WM show me just En 
Title: Re: Language Manager for VM 1.1
Post by: manHa on August 13, 2008, 16:55:58 pm
JFolder::create: Could not create directory
Component Install: Failed to create directory.: "/home/skinbox/public_html/administrator/components/com_martlanguages"





..........................
Title: Re: Language Manager for VM 1.1
Post by: brek on August 21, 2008, 18:25:59 pm
Hello

I didnt understand, everything i installed, and joomfish and language manager for vm and why when i change in joomfish corner another language  virtue mart text didnt change in another language, where i need to activate or smth ?? because i check in admin > com_virtuemart > languages > and everyting are , all translations files, but cant see in my site. please help me how to change language and in virtuemart.
Title: Re: Language Manager for VM 1.1
Post by: brek on August 23, 2008, 12:35:43 pm
no one cant help me??
Title: Re: Language Manager for VM 1.1
Post by: LaLa on August 26, 2008, 21:07:55 pm
i'm having the same problem... I downloaded the language tool as is develloped by the topicstarter, then I downloaded the languagepack and now I have a bunch of languages for the different virtuemart screens/parts. But it is impossible to use this tool to change the language on the site itself. I am starting to wonder what the intention of the developer was: just being able to translate the files, or also be able to incorporate them into the site. Or does that have to be done manually? I'm really at a loss here. Just as shown on the screenshots on the previous page it is possible to select the screen you wish to translate and to switch to that part and language, but applying the translated file to the site is a No-No.

If anyone could get in touch with the dev, it would be highly appreciated.
Title: Re: Language Manager for VM 1.1
Post by: LaLa on August 26, 2008, 21:17:45 pm
Well... after just f*cking around a bit, and using the preview site function in joomla itself, the language did switch to dutch in my case, so for me the problem seems to be solved for now, but it's not a true solution of course. Too bad, it would have been nice to be able to manage the languages on demand, or make it available to end users too. My opinion? Unbelievable that this isn't a native function of Virtuemart. Ah well... I guess we can't have it all, right?  ;)
Title: Re: Language Manager for VM 1.1
Post by: brek on August 27, 2008, 07:22:05 am
Lala,

Do u have any messenger? I want to talk to you.
Title: Re: Language Manager for VM 1.1
Post by: LaLa on August 28, 2008, 14:46:32 pm
I'm assuming you mean the topic starter. If not, and you want to talk to one of us, you can always send a private message, I think... most forums have that option. This one you can email people and I think use forum embedded messaging system?
Title: Re: Language Manager for VM 1.1
Post by: ruirui on October 06, 2008, 08:07:58 am
Warning: Invalid argument supplied for foreach() in ..\test\shop\administrator\components\com_martlanguages\admin.martlanguages.html.php on line 163

I'm getting this error while trying to use this component.

Is there something to do, or something I missed ?
Title: Re: Language Manager for VM 1.1
Post by: aurax on November 04, 2008, 10:43:35 am
Hi,

I'm experiencing some issues with language manager:

trying to translate virtuemart to hebrew (utf-8) i noticed that charset code (utf-8) in the language file is empty although i typed it in the language manager, second thing is i see the error:
Code: [Select]
Parse error: syntax error, unexpected T_STRING, expecting ')' in /home/yifahaz1/public_html/shop/administrator/components/com_virtuemart/languages/common/hebrew.php on line 392
Seems like langmanager component does not write "\'" where needed:

Code: [Select]
'PHPSHOP_FILES_NOT_FOUND' => 'Sorry, but the requested file wasn't found!',

Any workaround for this?


thank you!
Title: Re: Language Manager for VM 1.1
Post by: thorvar on November 08, 2008, 22:39:42 pm
I´ve installed the Language Manager, when I create new language edit and safe it, I'm not able to click on it to do some extra editing (translation),I only get empty document (white) any clue? :-o
Title: Re: Language Manager for VM 1.1
Post by: Pisu on November 19, 2008, 11:11:24 am
Warning: Invalid argument supplied for foreach() in ..\test\shop\administrator\components\com_martlanguages\admin.martlanguages.html.php on line 163
I'm getting this error while trying to use this component.
Is there something to do, or something I missed ?
What language are you trying to edit?
Title: Re: Language Manager for VM 1.1
Post by: Pisu on November 19, 2008, 11:48:26 am
Hi,
I'm experiencing some issues with language manager:
trying to translate virtuemart to hebrew (utf-8) i noticed that charset code (utf-8) in the language file is empty although i typed it in the language manager, second thing is i see the error:
Code: [Select]
Parse error: syntax error, unexpected T_STRING, expecting ')' in /home/yifahaz1/public_html/shop/administrator/components/com_virtuemart/languages/common/hebrew.php on line 392Seems like langmanager component does not write "\'" where needed:
Code: [Select]
'PHPSHOP_FILES_NOT_FOUND' => 'Sorry, but the requested file wasn't found!',Any workaround for this?
thank you!
Try manually change "wasn't" to "wasn\'t" in language file, and see if in next savings, it works...
Title: Re: Language Manager for VM 1.1
Post by: Pisu on November 19, 2008, 12:01:04 pm
I´ve installed the Language Manager, when I create new language edit and safe it, I'm not able to click on it to do some extra editing (translation),I only get empty document (white) any clue? :-o

Ok so it's the same issue as aurax. Please try installing the package attached. Let me know if anything works correctly.

[attachment cleanup by admin]
Title: Re: Language Manager for VM 1.1
Post by: aurax on November 20, 2008, 05:17:13 am
thank you, i will test it and report.
Title: Re: Language Manager for VM 1.1
Post by: arathra on January 19, 2009, 12:17:38 pm
I'm having a strange problem here.
I installed the language manager along with Greek (English is the default language).
The file (e.g. common/greek.php) is writeable. I edit an item and then click APPLY or SAVE at which point I am redirected to the Admin home page with no change being recorded.
Can anyone help with this?

As an update on this after more experimentation, it seems that some of the files will translate successfully; the one which never will, however, is common.php. That always returns me to the front page of admin with no changes.
Title: Re: Language Manager for VM 1.1
Post by: Imago on February 18, 2009, 01:47:35 am
Unfortunately, I can only confirm this. Files with no missing phrases are being edited successfully, while those with red fields are redirecting after Save or Apply to /administrator/index.php

This however is not a rule, as product/bulgarian.php has only white fields and still redirects to the admin homepage.
Title: Re: Language Manager for VM 1.1
Post by: lucato on April 24, 2009, 23:57:41 pm
Hi Pisu, nice to meet you.

What amazing tool, it will save a lot of time and will help a lot. The cool stuff is that also when I have a free time I'll get to help to increase the translation file in my language and submit it for the community. Well, when I get to make it works. :0)

I've tried it with IE8 and Firefox 3.0, but when I hit APPLY or SAVE, it isn't doing anything. I mean, after hitting one of them, the Joomla sends me to the administrator index page and my file is showing that is WRITEABLE. The Language folder is set as 755. I've also tried 777 and it didn't make any difference. I tried also to change the SITE and ADM default languages to English, just to don't leave active the "Current mosConfig_lang?" of the language file I was working on (editing), and it didn't solve too. All php language files are set as 644 attribute, is that correct?

Any help please? How do I get to SAVE/APPLY the changes?

Another comment, is about a suggestions. Well, actually I'm not sure if it is possible to do with LMVM now a days. But here it goes.

1) I'd like to create my own language for VM and load it just for VM and not as whole site/administrator Joomla. I mean, some actually I'd like to help to translate the original Language from my coutry with this community, but I'd like also to have my own language, once I'll translate some items for my needs and not as it should really be, so that's why I'd like to create a "differente Language only for VM". Is that possible? How do I load/use this my own created language?

2) Another suggestion that would be cool is get to duplicate an existing language by selecting the checkbox and hittin some button, DUPLICATE. So, it would create a new language, with all previous data from the source and not all empty as new one.

3) It would be cool to get to filter/sort by legend. So, I would select from a dropdown list the option "Missing" and it would show only the missing tokens. I would select "Needs Translation" and would show only tokens that need to be translated, and so on.;

4) coming soon...

Title: Re: Language Manager for VM 1.1
Post by: Pisu on April 26, 2009, 23:18:22 pm
I never had this problem. What language are you editing? Can you try with another language (e.g. Italian)? What version of Joomla?
Title: Re: Language Manager for VM 1.1
Post by: dionis13 on October 07, 2009, 14:08:20 pm
I could not change default language. I've just installed Russian language, but damn, could not understand how to switch to it... Sorry. please Help.
Title: Re: Language Manager for VM 1.1
Post by: Achileas on November 17, 2009, 20:20:31 pm
hi all, I can change my language at VM to english,france,german and it works korrect, but when I want to change the language to greek I only have hyroglyphs. Can someone help me please?
Mike

sorry for my english i´m german
Title: Re: Language Manager for VM 1.1
Post by: dveiga on May 01, 2010, 02:02:53 am
This link isnt valid anymore.. is there a language manager for 1.1.4?
Title: Re: Language Manager for VM 1.1
Post by: xeed on June 11, 2010, 21:26:18 pm
the download link is not working for me :(
Title: Re: Language Manager for VM 1.1
Post by: lindant on September 23, 2010, 12:57:16 pm
i need the language manager fo vm1.1.5
any updates please?
Title: Re: Language Manager for VM 1.1
Post by: affs70 on September 28, 2010, 01:21:39 am
This works for 1.1.5 VM version:

Go here "Download Section Other Downloads"
http://dev.virtuemart.net/redmine/projects/virtuemart/files

Look for  latest language pack, which is atm 1.1.4 file :"Language_Pack_for_VirtueMart_1.1.4.zip"

Download

Extract

Upload the files via FTP client to your webserver to the folder

/administrator/components/com_virtuemart/languages

Upload into each folder the language you want.

NOTICE

You need the same language installed to joomla administrator to make it work.

Example
If you use "german" inside joomla install "german" for VM.
If you use "germani" inside joomla install "germani" for VM.
 
Title: Re: Language Manager for VM 1.1
Post by: masky007 on September 30, 2010, 17:44:21 pm
ok but how do i change the language from any lang i have there in the folders?
however i am going to translate from eng to macedonain.. i hace to encode it to utf-8 without bom right?
Title: Re: Language Manager for VM 1.1
Post by: lindant on October 02, 2010, 10:36:08 am
Thank you affs70.
I actually copied the languages folder from the latest VM version and translated each file and named it to arabic, then upload on each folder.
I already have the language installed into joomla along with joomfish.
but one more thing, is there a latest CE VM plugin for joomfish ?

Thanks
Title: Re: Language Manager for VM 1.1
Post by: MKI-Miro on November 18, 2010, 07:53:09 am
is there any windows translator program, such as initranslator for ini files ?

thanks
Title: Re: Language Manager for VM 1.1
Post by: intradop on December 23, 2010, 03:47:01 am
Hi!
I'm using Virtuemart 1.1.6.
I tried to edit the portuguese common (1.1.4) and like for most in this thread, after saving, all special characters are being replaced with weired signs.
(Portuguese has plenty of them... ::)
Which is the latest compatible downloadable language manager and where do I find it?
thx
Title: Re: Language Manager for VM 1.1
Post by: kodrant on March 03, 2011, 18:15:00 pm
VM 1.1.7, Joomla 1.5.22, JoomFish, default language sr-RS, everything works fine except Virtuemart is not accepting some UTF8 characters in product description, category titles...once saved it turns to questionmarks ?????
Since this happens to be common issue, wonder if anyone had solved it?
ЂШЧЋЖЊЉ žćčšđ
Title: Re: Language Manager for VM 1.1
Post by: dillydally on March 20, 2011, 21:26:01 pm
For anyone at Virtuemart
- thanks for a great component and I know you put lots of work into it but ...
- it could save you loads of questions and frustrated users if you could possibly place a sticky with ALL language files and instructions in one (obvious) place.  I've seen a few notes but some of these are several years old and how to know if these are the only files (found some in other places) and if they are still relevant, up to date, etc.

I have spent days reading threads, uploading files and taking my site down and having to reload it again and again and again. I've read and re-read similar issues and please could you help us understand this language issue (which is big for many of us in the use of VM) better and follow a complete line of clear step by step instructions, especially the ones when it comes to updating the database as each time it has taken my site down.

I'm not even sure from the lack of responses on this issue whether it is worth posting my issue as I need to resolve it sooner rather than never.

Thanks but deeeeeeeply frustrated.
Title: Re: Language Manager for VM 1.1
Post by: viecol79 on March 29, 2011, 03:32:46 am
How many language the VM 1.1 can support?
Title: Re: Language Manager for VM 1.1
Post by: eitFlav on April 18, 2011, 18:54:45 pm
Hi everyone,

Thanks for all the work made in here !

Strange thing here :

I have a production website and a test website both in virtuemart 1.1.4. I installed the component at both web sites,but it only works for my test website !

Here is the thing : In my production website, when selecting the "common" category, it doesn't save my changes. I'm redirected to my administrator home page and nothing works.

The only category doing this strange bug is the "common" category, it works for all others.

Any suggestions ?

Thx a lot
Title: Re: Language Manager for VM 1.1
Post by: wehitch on October 24, 2011, 22:08:32 pm
Hello, i would like to know if there is a version of vm Language Manager that works with joomla 1.5.24,
Thank you in advance!
Title: Re: Language Manager for VM 1.1
Post by: giulliog3 on November 18, 2011, 00:30:34 am
and translation for Portuguese from Brazil
Title: Re: Language Manager for VM 1.1
Post by: solwininfotech on April 02, 2012, 09:16:13 am
Hello ,
I am using virtuemart 1.1.9 and joomfish 2.0.4 and joomla1.5.24. I am facing a problem in

language translation using joomfish.

I am using two languages English and spanish.

I set all the content in spanish and English in joomfish.

Problem is,
From front, When i am selecting spanish i can't see any changes in content and other palce.

It showing the content in english only.

I need to know , How can i fix this issue with joomfish?

Please reply ...

Thanks in advance