VirtueMart Forum

VirtueMart Dev/Coding Central: VM1 (old version) => Virtuemart 1.1 Development (Archiv) => Quality & Testing VirtueMart 1.1.x => Topic started by: Michael Mais on January 14, 2008, 06:53:27 am

Title: [TRACKER 1677] Invalid argument supplied for foreach() error message
Post by: Michael Mais on January 14, 2008, 06:53:27 am
How can that be? I did not have to change it in the past builds and it worked fine. However, my display is also gone haywire. Look at my latest screen

The Error seen is:

Warning: Invalid argument supplied for foreach() in /www/htdocs/.........../components/com_virtuemart/themes/default/templates/product_details/includes/addtocart_list_single.tpl.php on line 3

[attachment cleanup by admin]
Title: Re: Invalid argument supplied for foreach() error message
Post by: aravot on January 14, 2008, 08:04:31 am
Topic split not the same subject.

When do you get this error, i.e. while browsing or adding to cart?
Title: Re: Invalid argument supplied for foreach() error message
Post by: Michael Mais on January 14, 2008, 10:15:54 am
Browsing. I found that this particular picture happend when I check in VM administration the tab "Display options" the option "Use List box for child products" and no child is present.

I have another display problem, please see my post "dtree not switching to flypage". Maybe both are related and have nothing to do with the VM build. But I have no clue where to search.

You can see it live on http://www.ot-mais.com (http://www.ot-mais.com)

Michael
Title: Re: Invalid argument supplied for foreach() error message
Post by: aravot on January 15, 2008, 21:30:04 pm
Q&T note, tracker URL https://dev.virtuemart.net/cb/proj/tracker/itemDetails.do?task_id=1677