VirtueMart Forum

VirtueMart Dev/Coding Central: VM1 (old version) => Virtuemart 1.1 Development (Archiv) => Quality & Testing VirtueMart 1.1.x => Topic started by: unleash.it on December 20, 2007, 11:46:51 am

Title: [TRACKER 1617] Build 1097 won't install (on Joomla 1.5)
Post by: unleash.it on December 20, 2007, 11:46:51 am
I'm getting a fatal error when I try to install the latest build:

Update Log

    * Frontend Files successfully extracted.
    * Frontend Archive File successfully deleted.
    * Backend Files successfully extracted.
    * Backend Archive File successfully deleted.


Fatal error: Call to a member function get() on a non-object in C:\wamp\www\tom_and_daves\components\com_virtuemart\virtuemart_parser.php on line 52

I'm using Joomla 1.5 RC4 and php 5.2.5

The component installs successfully, but once I choose to install sample data I get the error. This also happens when I choose to go directly to store.There's nothing I can figure out to get it working so I'm going back to the previous nightly for now.
Title: Re: Build 1097 won't install (on Joomla 1.5)
Post by: Josué (Yosu) Cadilla Andrés on December 20, 2007, 12:42:25 pm
Did you activate the "Legacy mode"?
Title: Re: Build 1097 won't install (on Joomla 1.5)
Post by: unleash.it on December 20, 2007, 21:00:35 pm
Yes, the legacy plug in is enabled. I've been downloading each new build and testing VM 1.1 for several weeks. I never had problems installing it up until now.
Title: Re: Build 1097 won't install (on Joomla 1.5)
Post by: aravot on December 20, 2007, 23:21:01 pm
Already in tracker http://dev.virtuemart.net/cb/proj/tracker/itemDetails.do?navigation=true&task_id=1617
Title: Re: [TRACKER 1617] Build 1097 won't install (on Joomla 1.5)
Post by: dyrer on December 29, 2007, 20:40:32 pm
Same problem with 111 and tracker is not working :-[
Title: Re: [TRACKER 1617] Build 1097 won't install (on Joomla 1.5)
Post by: jenkinhill on December 29, 2007, 21:16:07 pm
The installation problem was fixed. VM 1111 installs just fine in J1.5 RC4 and later builds without using legacy mode. Still needs legacy for the mods, though.

If you can't install it check that the max upload file size in php.ini is set high enough - I use 4Mb.

And yes, the Codebeamer site is having issues right now.
Title: Re: [TRACKER 1617] Build 1097 won't install (on Joomla 1.5)
Post by: unleash.it on December 29, 2007, 23:04:30 pm
This may be a separate issue, but I recently (after the fix) had a similar installation issue. The component installed ok, but when installing sample data this time the error was:
Code: [Select]
Warning: require_once(C:\wamp\www\tom_and_daves/administrator/components/com_virtuemart//sql/sql.virtuemart.php) [function.require-once]: failed to open stream: No such file or directory in C:\wamp\www\tom_and_daves\administrator\components\com_virtuemart\install.php on line 136

Fatal error: require_once() [function.require]: Failed opening required 'C:\wamp\www\tom_and_daves/administrator/components/com_virtuemart//sql/sql.virtuemart.php' (include_path='.;C:\php5\pear') in C:\wamp\www\tom_and_daves\administrator\components\com_virtuemart\install.php on line 136

After installing that build and getting the error VM wouldn't uninstall, so I manually cleaned the Database and VM files. Tried reinstalling, same thing. Tried an earlier build, also same. Had to do a fresh Joomla/VM install to fix.

Title: Re: [TRACKER 1617] Build 1097 won't install (on Joomla 1.5)
Post by: aravot on January 03, 2008, 23:27:07 pm
@ unleash.it

Could not replicate your issue, which version of Joomla are you using.

Please try latest nightly build of VirtueMart (as of this post 1117) and report back, if you are installing on Joomla 1.5 make sure you have the latest version of that too, thank you.
Title: Re: [TRACKER 1617] Build 1097 won't install (on Joomla 1.5)
Post by: unleash.it on January 04, 2008, 23:51:33 pm
Avarot, the power is out over here in California so I can't get you the exact versions...but I install the new nightlies for both Joomla 1.5 and VM 1.1 almost daily. When I wrote the post it was Dec. 29...after the fix. As I mentioned, the problem was only fixed for me by doing a fresh install of both Joomla and VM (with the same builds). Since I restored the DB and my template, and everything was fine, I assume the problem was in the files. I think the problem is VM related, but I guess there's no way to know for sure.
Title: Re: [TRACKER 1617] Build 1097 won't install (on Joomla 1.5)
Post by: aravot on January 04, 2008, 23:54:46 pm
Where in California are you located, I am in L.A. (Glendale area) thank God we have power, let me know once you try it, I want to start closing old obsolete topics.
Title: Re: [TRACKER 1617] Build 1097 won't install (on Joomla 1.5)
Post by: unleash.it on January 06, 2008, 11:56:39 am
Glad to hear you're fine. I'm in Sonoma County, about an hour north of San Francisco. Near the edge of the middle of nowhere (and lots of fallen trees). The power finally came on this morning after a day+, just enough to thaw out the freezer. It wasn't the end of the world, candlelight has its pluses...

Well I still have that install around if it makes a difference. It was VM Build 1109 and Joomla 9741. To get VM installed, I was forced do a fresh Joomla install (with those same builds). That fixed the problem for me and since than I've been ok. If there's anything more I can do to help, let me know.