VirtueMart Forum

VirtueMart 2 + 3 => Product pricing => Topic started by: bbgol on June 06, 2021, 22:27:02 pm

Title: problem with rental equipment
Post by: bbgol on June 06, 2021, 22:27:02 pm
on my ecommerce I have rental products, I simply overide the askquestion item, so without putting any price, I get the tast ask question transformed into rental material .... my problem is that this item I can not show it on the home page, in the list of main products, the word "for hire" does not appear .... what can I do?
Title: Re: problem with rental equipment
Post by: Jörgen on June 06, 2021, 23:11:28 pm
Print screen images would help

Jörgen
Title: Re: problem with rental equipment
Post by: bbgol on June 07, 2021, 09:48:08 am
here is the print screen, in practice the first product is a rental product. by clicking on the product details the "ask question" button, translated into "rental material", comes out, but as you can see from the print screen the writing, instead of the price, does not come out
Title: Re: problem with rental equipment
Post by: Jörgen on June 07, 2021, 10:12:19 am
Sorry, this is linked to Your changes of addto cart. Maybe you should look into prices.php and see how prices are displayed. The categoriy template file may also need some changes.

I would also check how vmbeez3 or protostar templates display this.

Jörgen
Title: Re: problem with rental equipment
Post by: bbgol on June 07, 2021, 10:24:33 am
thanks for the reply, i also thought it could be a template problem. on another site with the horme3 template I didn't have the same problem ..... I try to check if it works with another template and check the price file
Title: Re: problem with rental equipment
Post by: bbgol on June 07, 2021, 10:28:23 am
I checked with the other templates, the result is the same. I try to check the price.php file
Title: Re: problem with rental equipment
Post by: bbgol on June 07, 2021, 14:54:09 pm
unfortunately the problem is not solved, I also tried to replace the price.php file, taking it from another site where the message is displayed, but still does not display. what else can i check?
Title: Re: problem with rental equipment
Post by: Jörgen on June 07, 2021, 15:11:13 pm
Compare Your template overrides, the answer should be there. This is something very specific to Your site. And not a VM bug.

Jörgen
Title: Re: problem with rental equipment
Post by: bbgol on June 07, 2021, 15:14:52 pm
ok, grazie