VirtueMart Forum

VirtueMart 2 + 3 => Administration & Configuration => Topic started by: valtermatias on November 01, 2019, 01:52:30 am

Title: New user
Post by: valtermatias on November 01, 2019, 01:52:30 am
Simply a new user tries to register on the site but gives no error but does not register, someone can help.
can see the page on https://sidepunt.com/index.php/home-virt/user/edit
Title: Re: NEW USER
Post by: hellorain on November 01, 2019, 05:17:12 am
Hi,

Please on error reporting from joomla configuration.

You will find issue.

Best Regards,
hellorain.
Title: Re: NEW USER
Post by: valtermatias on November 01, 2019, 07:57:59 am
Hello,

this was the answer from joomla support

Use the Developer tools option in Google Chrome - F12 - and check javascript errors from the Console.  The page has the following javascript error: edit:150 Uncaught TypeError: window.addEvent is not a function at edit:150 The registration page uses VirtueMart registration and you should post the issue to the VirtueMart forum.
Title: Re: New user
Post by: AH on November 01, 2019, 09:42:10 am
find out which javascript is conflicting with each other

Then fix
Title: Re: New user
Post by: StefanSTS on November 01, 2019, 10:35:54 am
Switch on user registration in Joomla user settings.

Title: Re: New user
Post by: valtermatias on November 01, 2019, 11:32:36 am
Hello,
new user registration is active.

check the attachment.
Title: Re: New user
Post by: StefanSTS on November 01, 2019, 11:50:10 am
That's fine then, just thought, because that problem was seen before.

If you want to make screenshots, switching to english sometimes helps the helpers.
I use this tool to quickly switch languages in backend in my test sites.

https://kubik-rubik.de/downloads/bls-backend-language-switcher/joomla-3
Title: Re: New user
Post by: valtermatias on November 01, 2019, 12:17:58 pm
I can't figure out what the problem is, and if disabling Virtuemart and sticking with the standard joomla registration form its works, if activating through virtuemart, doesn't work..
Title: Re: New user
Post by: StefanSTS on November 01, 2019, 13:07:56 pm
I see you use a script to disable right click and nonsense like that. You might want to change the template to Protostar or vmbeez3 and disable all extra JavaScript.

It might be a good step for getting closer to your problem.

Regards
Stefan
Title: Re: New user
Post by: valtermatias on November 01, 2019, 14:20:48 pm
Good, already done can check please