VirtueMart Forum

VirtueMart 2 + 3 => General Questions => Topic started by: confectionery on May 22, 2019, 14:01:02 pm

Title: can an php version cause errors
Post by: confectionery on May 22, 2019, 14:01:02 pm
Hi
I have just started to build a new website (and am very very rusty) and my php version on my laptop is outdated (wamp serve says 5.4.16).  I am using version version 3.4 virtuemart and version 3.9.6 for joomla.  I want to create an article and menu's etc. but I get these jce_com error messages and am wondering if it has to do with my php version?  Or did something go wrong with my installation.  Can anybody shed some light.
I should mention that version 2.4 wampserve
Title: Re: can an php version cause errors
Post by: StefanSTS on May 22, 2019, 14:30:05 pm
PHP 7.2 is a good choice to start with at the moment.
PHP 5.4 is definitely done.

Regards
Stefan
Title: Re: can an php version cause errors
Post by: confectionery on May 22, 2019, 14:39:34 pm
thank you, but do you think that that is what is causing my error messages in com_jce?
Title: Re: can an php version cause errors
Post by: StefanSTS on May 22, 2019, 15:04:12 pm
thank you, but do you think that that is what is causing my error messages in com_jce?

I have no idea, I can tell you after you have upgraded to a supported PHP version and told me if it works or not.

Title: Re: can an php version cause errors
Post by: GJC Web Design on May 22, 2019, 16:49:57 pm
It is only a warning ..  so u can stop them by reducing your reporting

But would assume upgrading to php7+ will throw even more warnings as its more picky

is your JCE up to date?
Title: Re: can an php version cause errors
Post by: confectionery on May 22, 2019, 17:04:35 pm
thank you.  I downloaded the latest version of jce - to my knowledge. I uninstalled and re-installed and it made no difference.  I dont know enough to go and see what the problem is, but it wont allow me to start articles etc.
Title: Re: can an php version cause errors
Post by: GJC Web Design on May 22, 2019, 19:26:15 pm
how can a simple php warning prevent the site working?

In any case .. as I said .. knock back your reporting level so the warning doesn't show

add

error_reporting( E_ERROR | E_PARSE | E_CORE_ERROR | E_CORE_WARNING | E_COMPILE_ERROR | E_COMPILE_WARNING );

to the site index.php
Title: Re: can an php version cause errors
Post by: StefanSTS on May 22, 2019, 20:50:24 pm
If more and more agonizing errors and warnings come up and you waste more and more of your time, you could also just install a new wamp with PHP 7.2.

Yes, or you just switch off error reporting and put it on a live server later that will run on PHP 7.1 or above and start the error search again for the errors that were no errors in PHP 5.4, but now in PHP 7.x.

Error producing and error searching is a nice hobby though, if you don't really want to efficiently build a website that is a good way to learn.

Have fun whichever way you go.
Stefan
Title: Re: can an php version cause errors
Post by: behemoth on May 23, 2019, 13:37:51 pm
System > Global Config
Select 'Server' tab
Change 'Error Reporting' to 'None'.
Title: Re: can an php version cause errors
Post by: Milbo on May 24, 2019, 08:02:53 am
as far as I know, php5.3,5.6,7.x are good. All versions in between are bad. PHP5.4 was never used a lot. Most people jumped from 5.3 to 5.6 directly, imho. But anyway, anything below php 7.0 should not be used anylonger.
Title: Re: can an php version cause errors
Post by: confectionery on May 24, 2019, 16:40:58 pm
Thank you guys, you have all been a great help.  behmoth, I switched the report to 'none' and the messages did disappear.  However, could still not load articles.  Wont bore you all with the long sordid story. But I installed latest version of wamp server with all the latest versions of joomla and virtuemart ... So far so good.  As I say I am technically challenged and can only summise that working with the latest versions has helped.  Once again, thank you!