VirtueMart Forum

VirtueMart 2 + 3 => Frontend Modules => Topic started by: wicko on December 20, 2018, 01:35:13 am

Title: VM category menu module not showing
Post by: wicko on December 20, 2018, 01:35:13 am
Having setup VM on my site and produced several products and categories ok. I have create an initial (Category) menu in my main menu to load the shop. This displays all products ok. But I wanted to create a category menu so I have published the VM category module to show on the left side column of my shop. But when I load the shop nothing displays in the left column. I first I though it was a template issue but I was able to publish a custom module to the same location ok. Any idea why the VM Category Menu doesn't show?

I also tried to create individual category menu in a drop down from the main shop menu. But this caused a time out error and I was unable to load a specific category

https://wickodev.uk (https://wickodev.uk)
Title: Re: VM category menu module not showing
Post by: GJC Web Design on December 20, 2018, 09:42:59 am
VM categories published?

all your cat menus fail

https://wickodev.uk/index.php?option=com_virtuemart&view=category&virtuemart_category_id=17

https://wickodev.uk/index.php?option=com_virtuemart&view=category&virtuemart_category_id=1&Itemid=145

Maximum execution time of 30 seconds exceeded
Title: Re: VM category menu module not showing
Post by: wicko on December 20, 2018, 15:36:01 pm
How did I miss that. I just presumed that the categories were published as products from the categories were showing.
All working fine now

Thank you
Title: Re: VM category menu module not showing
Post by: GJC Web Design on December 20, 2018, 15:59:02 pm
cats are always created unpublished as you can do very useful things with unpub cats (discounts etc)