VirtueMart Forum

VirtueMart 2 + 3 => Administration & Configuration => Topic started by: mailblade on January 07, 2018, 15:35:31 pm

Title: Images on PDF header & footer not loading?
Post by: mailblade on January 07, 2018, 15:35:31 pm
Good day

I am wondering why the images I have inserted into my PDF header and footer are not loading.

Everything was working fine a month ago. I left on vacation and came back to work today. For some reason, the images are not loading in the PDF. By "Shop -> Invoices/Emails" I added a header and footer. The text is loading fine, but no images.

I'm 100% sure I didn't change anything to disable the images, so it's very strange.

Anyone know what this could be?
Title: Re: Images on PDF header & footer not loading?
Post by: Jörgen on January 07, 2018, 16:59:53 pm
Any update done lately that could explain this ?

regards

Jörgen @ Kreativ Fotografi
Title: Re: Images on PDF header & footer not loading?
Post by: mailblade on January 07, 2018, 17:17:46 pm
Thanks for the reply Jorgen

No, I can not think of anything. I did my last test order on 25 November 2017 and the images were loading fine. Could a clash in scripts or other plugins maybe be the cause?

I believe I did do a backup of the site, so I'll just have to reinstall that version if it doesn't work.
Title: Re: Images on PDF header & footer not loading?
Post by: jenkinhill on January 07, 2018, 18:41:18 pm
Have you checked for server updates? eg PHP version
Title: Re: Images on PDF header & footer not loading?
Post by: mailblade on January 07, 2018, 20:53:24 pm
Hi Jenkinhill

I am still on PHP 5.5.

I can upgrade to 7 though I'm not sure how many things won't work once I do that.

Thanks guys I think I possibly may have influenced it by installing some other plugins or components. Will have to go back step-by-step and see what's wrong.
Title: Re: Images on PDF header & footer not loading?
Post by: mailblade on January 07, 2018, 21:39:16 pm
Okay I just noticed something.

It's working when I use an image from an external website as a "src" for the image, but not one from my own website.

I'll try and use a sub-directory instead of the root and see if that works.
Title: Re: Images on PDF header & footer not loading?
Post by: mailblade on January 08, 2018, 08:46:36 am
EDIT

Guys.. I have solved it. You won't believe it. The issue is that my images were transparent! So please note, tcpdf can't display transparent images in the PDF.

Very noob mistake by myself. The funny thing is, it still runs on older versions of the site even though I use the same transparent images. So I removed all transparency and now it works.

Thanks for the tips!