VirtueMart Forum

VirtueMart 2 + 3 => Virtuemart Development and bug reports => Topic started by: gba on January 02, 2018, 16:39:04 pm

Title: Frontend login not possible after VM update v3.2.12
Post by: gba on January 02, 2018, 16:39:04 pm
Hi!

I updated VM from v3.2.5 to v3.2.12.
Now on opening ".../mein-konto/" I get following VM debug information:
Quote
NACHRICHT
1 vmdebug Show All Errors, PHP-Version 7.0.25
2 vmdebug 2 Languages, default shoplanguage (VmConfig::$jDefLang): de_de de-DE Selected VM language (VmConfig::$vmlang): de_de de-DE SEF: de
3 vmdebug vmTime: time to load config: 0.00366687774658203
4 vmdebug Start used Ram 2M
5 vmdebug Common jQuery is disabled
6 vmdebug SSL enabled
7 vmdebug getBTuserinfo_id is 0
8 vmdebug Try to get $virtuemart_userinfo_id by type BT
9 vmdebug getUserInfoInUserFields case empty $uid
10 vmdebug Common jQuery is disabled
11 vmdebug My Url in loginform Var1:
index.php?option=com_virtuemart&view=user&layout=edit&language=de-DE&Itemid=449&lang=de-DE
12 vmdebug End used Ram 2M
13 vmdebug Peak memory peak 2M
14 vmdebug vmTime: "VirtuemartControllerUser" Finished task : 0.113359928131104
15 vmdebug Common jQuery is disabled
16 vmdebug Common jQuery is disabled
On logging in in FE the URL changes to ".../mein-konto/edit?limitstart=0&limit=150&language=de-DE" and I get following VM debug information:
Quote
NACHRICHT
1 vmdebug Show All Errors, PHP-Version 7.0.25
2 vmdebug 2 Languages, default shoplanguage (VmConfig::$jDefLang): de_de de-DE Selected VM language (VmConfig::$vmlang): de_de de-DE SEF: de
3 vmdebug vmTime: time to load config: 0.0106790065765381
4 vmdebug There is no requested itemid loaded home Itemid Var1:
333
5 vmdebug Start used Ram 2M
6 vmdebug Common jQuery is disabled
7 vmdebug SSL enabled
8 vmdebug getBTuserinfo_id is 0
9 vmdebug Try to get $virtuemart_userinfo_id by type BT
10 vmdebug getUserInfoInUserFields case empty $uid
11 vmdebug Common jQuery is disabled
12 vmdebug My Url in loginform Var1:
index.php?option=com_virtuemart&view=user&layout=edit&limitstart=0&limit=150&language=de-DE&Itemid=449&lang=de-DE
13 vmdebug End used Ram 2M
14 vmdebug Peak memory peak 2M
15 vmdebug vmTime: "VirtuemartControllerUser" Finished task : 0.125089168548584
16 vmdebug Common jQuery is disabled
17 vmdebug Common jQuery is disabled
User is logged in, but no user data is displayed and var_dump($user) returns:
Code: [Select]
object(Joomla\CMS\User\User)#47 (26) { ["isRoot":protected]=> bool(false) ["id"]=> int(0) ["name"]=> NULL ["username"]=> NULL ["email"]=> NULL ["password"]=> NULL ["password_clear"]=> string(0) "" ["block"]=> NULL ["sendEmail"]=> int(0) ["registerDate"]=> NULL ["lastvisitDate"]=> NULL ["activation"]=> NULL ["params"]=> NULL ["groups"]=> array(1) { [0]=> string(1) "9" } ["guest"]=> int(1) ["lastResetTime"]=> NULL ["resetCount"]=> NULL ["requireReset"]=> NULL ["_params":protected]=> object(Joomla\Registry\Registry)#51 (3) { ["data":protected]=> object(stdClass)#52 (0) { } ["initialized":protected]=> bool(false) ["separator"]=> string(1) "." } ["_authGroups":protected]=> NULL ["_authLevels":protected]=> array(3) { [0]=> int(1) [1]=> int(1) [2]=> int(5) } ["_authActions":protected]=> NULL ["_errorMsg":protected]=> NULL ["userHelper":protected]=> object(Joomla\CMS\User\UserWrapper)#50 (0) { } ["_errors":protected]=> array(0) { } ["aid"]=> int(0) }$user->guest is 1.

What is going wrong here?

Kind regards,
Gerald
Title: Re: Frontend login not possible after VM update v3.2.12
Post by: gba on January 03, 2018, 12:33:25 pm
Hi!

For anyone who will have the same issue:
It seems as if the browser had a cookie problem.
After deleting cookies login works.

Kind regards,
Gerald