VirtueMart Forum

VirtueMart 2 + 3 => Installation, Migration & Upgrade => Topic started by: dariuszelvys on June 13, 2017, 23:11:03 pm

Title: Desperate need in help...
Post by: dariuszelvys on June 13, 2017, 23:11:03 pm
Hi guys, i'm in desperate need of a help.
After migrating and updating virtuemart to 3.2.3 , and joomla to 3.7.2 and shaper helix3 template i noticed a strange thing...
Using PHP 7.0 btw.

http://www.agropartsbaltija.lt
If i use firefox browser, everything works, i can add products to cart, delete them, checkout (VM one page module).
If i use chrome - i get that stuck screen and it doesnt go away. It comes, when i try to select payment, of change the quantity in cart. It used to work, but i can't say which is the last version it worked.

Tried to play with jquery easy module - didn't help.
Any help would be greatly appreciated.
It's not related to template, cause the same thing happens with other templates.
Title: Re: Desperate need in help...
Post by: dariuszelvys on June 13, 2017, 23:17:21 pm
and one more thing. I can't even add products to cart in chrome if  Display modal popup upon 'Add to cart'  is selected in config.
Title: Re: Desperate need in help...
Post by: Milbo on June 14, 2017, 10:19:32 am
Looks like Javascript problems, but when I enter your page I get "Call to a member function NewColorizeImage() on null" and we do not use this function. Seems to be some overrides.
Title: Re: Desperate need in help...
Post by: dariuszelvys on June 14, 2017, 12:12:34 pm
Now it's working, could you please help me. I think i've tried everything i could...
Title: Re: Desperate need in help...
Post by: dariuszelvys on June 14, 2017, 14:58:24 pm
Further story: Restored from backup site, that has  3.7.0 , and other parts fully updated. And to my suprise, it works. Almost everything, just fancybox fails, other parts work perfect. Really afraid to push update button :D
Title: Re: Desperate need in help...
Post by: dariuszelvys on June 14, 2017, 15:24:32 pm
And of course, our 3rd party payment system works with fancybox popup too...
Damn.. Could somebody please help
Title: Re: Desperate need in help...
Post by: GJC Web Design on June 14, 2017, 15:47:59 pm
the FIRST thing to do is clone the site so u have a safe place to work with it!!!
Title: Re: Desperate need in help...
Post by: dariuszelvys on June 15, 2017, 09:15:00 am
Fully updated site :) And guest what. FancyBox is not working...  Could anybody please help me?
Title: Re: Desperate need in help...
Post by: Milbo on June 15, 2017, 10:00:43 am
Disable the override for productdetails and test then.
Title: Re: Desperate need in help...
Post by: dariuszelvys on June 15, 2017, 11:25:54 am
Template i'm using doesn't have any ovverides for virtuemart
Title: Re: Desperate need in help...
Post by: dariuszelvys on June 15, 2017, 11:46:55 am
Strange things happening. Updated to com_virtuemart.3.2.3_extract_first.9579
And everything works now.
Title: Re: Desperate need in help...
Post by: layman on October 10, 2017, 12:40:10 pm
A similar situation
Made a copy of Joomla 3.8.1, vm 3.2.4, php 5.6.31.
Unpacked on another server with PHP 7.1.9 the admin panel works. shows up on the website error (error 0 Call to a member function NewColorizeImage() on null)  >:(
Changed PHP 5.6.31 - site works :D. Went back to PHP 7.1.9 freewheeling on top of the vm 3.2.4 - all works  :D
Title: Re: Desperate need in help...
Post by: jenkinhill on October 10, 2017, 13:37:32 pm
NewColorizeImage is not a default VM function so the error must be from some 3rd party plugin or other extension.