VirtueMart Forum

VirtueMart 2 + 3 => General Questions => Topic started by: ukfish1 on January 04, 2017, 11:57:26 am

Title: Virtuemart Products module breaking site
Post by: ukfish1 on January 04, 2017, 11:57:26 am
ref: http://www.britishshoecompany.co.uk

VM     3.0.18
Joomla 3.6.5

When I enable the Virtuemart Products module on the homepage at the above URL, it causes a blank page to be displayed. When I disable the module, the page displays normally.

Any ideas why this might be. It was working when the site was first launched but recently it has started causing this problem.

thanks, Paul
Title: Re: Virtuemart Products module breaking site
Post by: jenkinhill on January 04, 2017, 12:24:28 pm
Blank page with Joomla usually indicates a 500 error. See http://forum.virtuemart.net/index.php?topic=117042.0
Title: Re: Virtuemart Products module breaking site
Post by: ukfish1 on January 04, 2017, 12:40:43 pm
Host company reported this error. Would that have something to do with it.

[03-Jan-2017 15:55:47 UTC] PHP Fatal error:  Class 'shopFunctionsF' not found in /home/shoe1/public_html/administrator/components/com_virtuemart/models/product.php on line 1510
[03-Jan-2017 16:05:10 UTC] PHP Fatal error:  Class 'shopFunctionsF' not found in /home/shoe1/public_html/administrator/components/com_virtuemart/models/product.php on line 1510
[03-Jan-2017 16:05:14 UTC] PHP Fatal error:  Class 'shopFunctionsF' not found in /home/shoe1/public_html/administrator/components/com_virtuemart/models/product.php on line 1510

thanks, Paul
Title: Re: Virtuemart Products module breaking site
Post by: jenkinhill on January 04, 2017, 12:53:44 pm
That error in 3.0.18 was fixed a few sub-versions ago.  http://forum.virtuemart.net/index.php?topic=135958

We now use 3.0.18.7
http://dev.virtuemart.net/attachments/download/1038/com_virtuemart.3.0.18.7_extract_first.zip
Title: Re: Virtuemart Products module breaking site
Post by: ukfish1 on January 04, 2017, 13:10:01 pm
hi

I have updated to 3.0.18.7 and now I get the following

http://www.britishshoecompany.co.uk/styles/brogue

Paul


Title: Re: Virtuemart Products module breaking site
Post by: Jörgen on January 04, 2017, 13:36:10 pm
There has been som Changes in the layout and what You assign as the start page.

Please check the assigned menu item for virtuemart.

There are also new configuration under configuration for virtuemart that should be checked.

regards

Jörgen @ Kreativ Fotografi
Title: Re: Virtuemart Products module breaking site
Post by: jenkinhill on January 04, 2017, 15:04:59 pm
You updated a live site without testing first?  Looks to me like a sef or template issue, plus as Jörgen says, menus items now have their own configuration, and the old VM "home page" is deprecated. .

If you did not update your template overrides for VM3.0.18 that may still need doing - last paragraph in the new release, http://virtuemart.net/news/latest-news/477-release-of-3-0-18-connecting-the-loose-ends