VirtueMart Forum

VirtueMart 2 + 3 => Virtuemart Development and bug reports => Development & Testing => Topic started by: John2400 on June 19, 2012, 14:07:11 pm

Title: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
Post by: John2400 on June 19, 2012, 14:07:11 pm
This is not the invoice sent to customers. ( Has nothing to do with the emails)

the PDF creation in the orders area in the backend.

* The print option works well but the PDF file will not display.

* infact it does work on an odd invoice now and again - but for all types of browsers it just shows a blank page.  The page hangs for a good 5 minutes.

And I am confirming I have tried all the settings in the configuration - checkout area and then set all products to my confirmed setting and saved them. (emails arrive with a PDF invoice but the invoice in orders does nothing) - can someone test or confirm>

I have updated to 2.5.6 joomla  but this was not working for a few days and I was waiting to see if others posted something similar. ( so 2.5.4 it did not work as well)
Title: Re: 2.0.7 G PDF in the invoice orders not working - Backend
Post by: alatak on June 20, 2012, 22:34:12 pm
Hello John2400

I don't have problem.

Can you check in the configuration in the tab "checkout" the parameter "Default Order Status to send an invoice".

which payment method do you use?
Is the invoice created? if yes, can you check on the invoice path , that it has been correctly created?
Title: Re: 2.0.7 G PDF in the invoice orders not working - Backend
Post by: John2400 on June 20, 2012, 23:37:22 pm
mmm,

The software works - but it hangs - again I did it this morning - after I click the first and it shows- close the window- the second just hangs .

So yes it works - but it is opening them - I have the best - adobe software on my computer so reading the pdf is not the isssue.

This is after setting shipped in configuration as the default invoice , then changing it to shipped, then saving and receiving an email. I then click on Invoice. and the image you see comes up.  Again. the emails are perfect- with the invoice attached.

* I just think at the end of the financial period people are going to print their invoices - from this part of the computer and the first might be ok - the second ?

path:  or the one that does not open

 http://www.mmmmmmmm.com.au/index.php?option=com_virtuemart&view=invoice&layout=invoice&format=pdf&tmpl=component&virtuemart_order_id=176&order_number=8989034&order_pass=p_37a9c

[attachment cleanup by admin]
Title: Re: 2.0.7 G PDF in the invoice orders not working - Backend
Post by: Milbo on June 21, 2012, 00:57:48 am
Can you open the pdfs which are attached to the email? Or is it just a problem with the pdfs created in the BE?

For me it looks like an error due not tcpdf compatible images, use jpg.
Title: Re: 2.0.7 G PDF in the invoice orders not working - Backend
Post by: alatak on June 21, 2012, 08:31:21 am
Hell John2400,

The invoices are stored under your safe path.
Can you upload one of them, and check if you can open it directly with a PDF reader?

For me also it looks like a PDF creation problem.
Title: Re: 2.0.7 H PDF in the invoice orders not working - Backend
Post by: John2400 on June 21, 2012, 13:40:42 pm
The invoices are OK - in the emails .
-------------------------------------------------------------------------------------------------------------------
All in the back end.

* I went to my orders - and then decided to delete the test ones - under G I cannot delete the old ones -. I remember this in some previous version.

Some of the new ones I could delete - (new dates)

* Then thought that if the orders were deleted then the PDF files would be deleted and I could test a new one.

At the moment it just looks too untidy It is a little beyond me -

Alatak - The pdfs in the safe folder do open with a pdf reader

-----------------------------------------------------------------------------------------------------------------------
In the backend If I click on an invoice I get nothing _ a if I click on print In orders i get this

createInvoiceNumber $orderDetails has no virtuemart_order_id

Title: Re: 2.0.7 G PDF in the invoice orders not working - Backend
Post by: John2400 on June 21, 2012, 23:58:13 pm
Update:

If I try to delete my invoices:

I get vmError:
vmError: VirtueMartModelOrders::remove 163
Order could not be deleted.

This is on only some of them- about 20 in total.
Title: Re: 2.0.7 H PDF in the invoice orders not working - Backend
Post by: John2400 on June 25, 2012, 08:21:12 am
I think this post of mine is related - http://forum.virtuemart.net/index.php?topic=103126.msg346811#msg346811
Title: Re: 2.0.7 H PDF in the invoice orders not working - Backend
Post by: John2400 on June 26, 2012, 13:12:07 pm
Hi ,

Just so you can see what invoices are not deleting in the back end -  Please note that they have no name related to the product .

How did this occur - When I went to create a new user in Joomla the software in G version created a user with two emails addresses .

In the shoppers additional information it automatically put the vendors email and in the general users information email it put the one I created. When I ordered a product the invoice then created an invoice with with blank information -

I have no idea how or why this happened but now I have these invoices that just sit in the system -- If some one could tell me where I could delete  these or how.

Can I go Into Mysql and delete them from there ?  you will have to tell me the exact table ?  If not just tell me to wait for an update and see If they can delete from there.

yes I am using H version Now.

[attachment cleanup by admin]
Title: Re: 2.0.7 H PDF in the invoice orders not working - Backend
Post by: John2400 on June 26, 2012, 23:03:13 pm
Version 'I"

I tested and set quite a few emails - The invoice when shipped - sends a PDF and  yes - and I can open that PDF from the "safe file" and from the emails to the customer and seller/vendor.   But the initial issue below is the same - I cannot open the PDF files (invoices) from the back end of the VM system. A blank page shows.

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
This is not the invoice sent to customers. ( Has nothing to do with the emails)

the PDF creation in the orders area in the backend.

* The print option works well but the PDF file will not display.

* infact it does work on an odd invoice now and again - but for all types of browsers it just shows a blank page.  The page hangs for a good 5 minutes.

And I am confirming I have tried all the settings in the configuration - checkout area and then set all products to my confirmed setting and saved them. (emails arrive with a PDF invoice but the invoice in orders does nothing) - can someone test or confirm>

I have updated to 2.5.6 joomla  but this was not working for a few days and I was waiting to see if others posted something similar. ( so 2.5.4 it did not work as well)
Title: Re: 2.0.7 I PDF in the invoice orders not working - Backend
Post by: John2400 on June 27, 2012, 13:01:37 pm
Hi I tried to find the Data base to delete just one order - number 163/
Turned on the bug report and then clicked delete.

vmdebug self::$_jpConfig->lang en_gb
vmdebug vmTime: loadConfig db no: 0.00369501113892
vmError message empty
#0  vmTrace(vmError message empty) called at [/home/xxxxxxx/public_html/administrator/components/com_virtuemart/helpers/config.php:125]
#1  vmError() called at [/home/xxxxxx/public_html/administrator/components/com_virtuemart/tables/orders.php:153]
#2  TableOrders->delete(163) called at [/home/xxxxxx/public_html/administrator/components/com_virtuemart/models/orders.php:1284]
#3  VirtueMartModelOrders->remove(Array ([0] => 163)) called at [/home/xxxxx/public_html/administrator/components/com_virtuemart/helpers/vmcontroller.php:204]
#4  VmController->remove() called at [/home/xxxxxx/public_html/libraries/joomla/application/component/controller.php:760]
#5  JController->execute(remove) called at [/home/xxxxx/public_html/administrator/components/com_virtuemart/admin.virtuemart.php:81]
#6  require_once(/home/xxxxxxa/public_html/administrator/components/com_virtuemart/admin.virtuemart.php) called at [/home/xxxxxx/public_html/libraries/joomla/application/component/helper.php:383]
#7  JComponentHelper::executeComponent(/home/xxxxxxx/public_html/administrator/components/com_virtuemart/admin.virtuemart.php) called at [/home/xxxxxx/public_html/libraries/joomla/application/component/helper.php:351]
#8  JComponentHelper::renderComponent(com_virtuemart) called at [/home/xxxxxxx/public_html/administrator/includes/application.php:153]
#9  JAdministrator->dispatch() called at [/home/xxxxxx/public_html/administrator/index.php:46]
vmdebug self::$_jpConfig->lang en_gb
vmdebug vmTime: loadConfig db no: 0.00385689735413

I tried this _this is the print out from the Invoice (print symbol) Message
vmdebug self::$_jpConfig->lang en_gb
vmdebug vmTime: loadConfig db no: 0. 00400996208191
vmdebug Start used Ram 12.25M
vmdebug createInvoiceNumber $orderDetails has no virtuemart_order_id Var1:
Array
(
)

vmdebug vmTime: VirtuemartControllerInvoice Finished task : 0.263660907745
vmdebug End used Ram 30.25M
vmdebug Peak memory peak 30.25M
Warning
createInvoiceNumber $orderDetails has no virtuemart_order_id

I now have deleted from the MYSQL - table all entries from 1) virtuemart_orders, 2) the invoices, 3) the histories 4) and order items (now)

This did not work and I can still see these entries in The Orders - invoices in the backend.
Title: Re: 2.0.7 I PDF in the invoice orders not working - Backend
Post by: Milbo on June 27, 2012, 22:28:45 pm
order_items also belong to it
Title: Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
Post by: jack19 on July 25, 2012, 19:10:12 pm
Hi,
I think I have a similar problem. I am using Joomla 2.5.6 - VM 2.0.8e.
The PDF file is incorrect, the one sent by email is blank, there is only the header.
The PDF files generated by back-end contains only one line and up the order number.
Only the print file to back-end is quite good, the only problem is that the logo is printed under the name of the shop and it appears small, (as if it came from the thumbnail).
I attach some screenshots to make better

[attachment cleanup by admin]
Title: Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
Post by: John2400 on July 25, 2012, 23:24:09 pm
Hi Jack,

Interesting as you can see I have posted earlier in regards to this issue. The team spent a great deal of time in 2.0.8 c,d,e fixing this issue.  My site no longer has this problem and I only updated the software - no hacks in the code.

Can you try and reinstalling 2.0.8 e version again over the top. I write just to say it was for me fixed.
Title: Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
Post by: jack19 on July 26, 2012, 09:31:03 am
Hi Jack,

Interesting as you can see I have posted earlier in regards to this issue. The team spent a great deal of time in 2.0.8 c,d,e fixing this issue.  My site no longer has this problem and I only updated the software - no hacks in the code.

Can you try and reinstalling 2.0.8 e version again over the top. I write just to say it was for me fixed.
Hi John
Do you mean uninstall and reinstall the same version?
I used the version 2.0.8E.
For your information I am doing the test in localhost.
Title: Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
Post by: John2400 on July 26, 2012, 09:50:45 am
no just install it over the top again.
Title: Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
Post by: jack19 on July 26, 2012, 10:06:19 am
no just install it over the top again.
Hi John,
I installed it again, unfortunately does not work.  :(
Title: Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
Post by: jack19 on July 26, 2012, 12:32:36 pm
I was thinking is that it does not work using a local web?
Can anyone encounter this?
Title: Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
Post by: markito on May 26, 2013, 08:55:03 am
Hi,

for me the same problem. by 3 different installations.

- The PDF files generated by back-end is empty.
- The print file generated by back-end looks good.

everything currently:
Joomla 2.5.11 - VM 2.0.20b.

Title: Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
Post by: lindapowers on May 26, 2013, 10:48:43 am
I was thinking is that it does not work using a local web?
Can anyone encounter this?

Yes PDF files appear blank in a local installation even if is an exact copy of a live site where PDF's work.
Title: Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
Post by: markito on May 26, 2013, 13:33:43 pm
in my case, there are 3 different live sites on 2 different hosting provider
where the PDF files in the back-end are empty.

one fresh install and two migrated VM

Title: Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
Post by: Milbo on May 27, 2013, 19:33:52 pm
It depends on your server, which images/fonts are supported. But for me there is no difference
Title: Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
Post by: lindapowers on June 13, 2013, 04:12:16 am
It depends on your server, which images/fonts are supported. But for me there is no difference

So is there something specific server needs? Something we should require to our hosting?

We use a JPG for the vendor image and we have tested the 3 fonts available for the invoices.

in my case, there are 3 different live sites on 2 different hosting provider
where the PDF files in the back-end are empty.

one fresh install and two migrated VM



Did you find a solution Markito?

I'm having exactly the same. I though it was cause due to a local installation but updating VM  from 2.020b to 2.021D in a live site didn't solve this issue. Now I see delivery notes, which as invoices, show blank.

Could the safe path affect in any way?

Regards
Title: Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
Post by: Milbo on June 14, 2013, 11:52:34 am
I take a look with you via skype and maybe we can add a message explaing the problem and how to solve it. Blank page is always shit.
Title: Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
Post by: lindapowers on June 14, 2013, 13:27:10 pm
Hi I just reinstalled VM2 and now is working, the only difference is that after installing the AIO this time i didn't update the tables.

Have no clue really but anyway now it works in 2.021D version.
Title: Re: 2.0.7 PDF in the invoice orders not working - Backend fixed in 2.08
Post by: Milbo on June 14, 2013, 13:40:33 pm
Please read here further http://forum.virtuemart.net/index.php?topic=116347.0
This post was only for the 2.0.8 version