VirtueMart Forum

VirtueMart 2 + 3 => Virtuemart Development and bug reports => Topic started by: e-trader on April 05, 2012, 14:50:46 pm

Title: 1.1 to 2.08E migration does not migrate currency for orders
Post by: e-trader on April 05, 2012, 14:50:46 pm
Hi Guys,

Upgrading from 1.17b to 2.02 the ORDER_CURRENCY in the DB is not migrated when using the migration tool. The new value is always NIL instead of the actual currency used.

Is a fix planned for this?

Thanks for any reply.
Title: Re: 1.1 to 2.02 migration does not migrate currency for orders/item details
Post by: Milbo on April 05, 2012, 21:07:35 pm
Hmm you could use the latest version J http://forum.virtuemart.net/index.php?topic=100791.0
Title: Re: 1.1 to 2.02 migration does not migrate currency for orders/item details
Post by: e-trader on April 06, 2012, 11:38:37 am
Good point, was there a fix specifically for this? OK I have re-tested migration with version v2.03j downloaded form your link down.

After the migration the v2.03j database tables show:

JOS_VIRTUEMART_ORDERS field ORDER_CURRENCY value NULL  (and user_currency_ID null)
JOS_VIRTUEMART_ORDER_ITEMS field ORDER_ITEM_CURRENCY value 0

In my case the currency values from v1.17 were not migrated.
Do you get different test results?
Title: Re: 1.1 to 2.02 migration does not migrate currency for orders/item details
Post by: e-trader on July 24, 2012, 22:51:28 pm
Testing VM 208E when migration from 1.17 to 2.08e the historical orders and products within the historical orders do not have the correct currency associated with them. It shows the default vendor currency instead of the currency the order was done in.

(the good news was that the products (not part of saved orders) did have the correct currency associated with them now after migration - THANKS).

Is it something that can be looked in to please?